summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /dev-python/sphinxcontrib-qthelp
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.7.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index 9e91f2cf7441..c59bb3b6ac4f 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_qthelp-1.0.6.tar.gz 16555 BLAKE2B 7fabbd35f5ccf5895f16fd17e335268445e32ee0cb8c596c68e537169d4ad0aa3dc102ee2474c136c62676cff6ab639288c5fff4892d78a257a85a7ab963fe9d SHA512 783cd757bf262ce63f54019a5ccf1d7e6fb59e8fde07e7cfa0610bf0cd49e6e51cada9c35bf11cc5ff351904da6a69569be1d4db58d450a96375aee7bf1f34ff
+DIST sphinxcontrib_qthelp-1.0.7.tar.gz 16685 BLAKE2B dbe4518134f31f9283a1de4a9f7c1b1fd59e3c639923dd5a84fe1c60323f8c0fbf31942ab51724241bf8865b78c5c83bc7c2187d7209b1c55027245cae2bd271 SHA512 fa11be5f663a0784a59ee18deaa8d497eeb4d5311fd86f75d48f40b70d8c0c868bd8625a001da274379d2b3412447abd810cb44af42f8a252cbcc31c400884c9
EBUILD sphinxcontrib-qthelp-1.0.6.ebuild 714 BLAKE2B 49ea74af3f60c1590be868d01e9430403bc2a1c2faa48e287f2478cf1615616f0d0b2ad6da1fd3824b553fc06aedf5463ed863fac9642f64f351a8b635abd172 SHA512 4807497c5370f2e875bf3529b2b88a7d7e10672ffce3943aa0c5fda073835099db8e56a2709515c5be8e9ded82b8d132a1a2dc627a78b23d70ee721680f676d9
+EBUILD sphinxcontrib-qthelp-1.0.7.ebuild 722 BLAKE2B 6be1917b1069cffb38aecc96582470adbe8a3773150a05e65747e3eb085e3cfb3c16309f52e2029d828eb5bfb742f0555b528573c3691deb278da35a9adb36cc SHA512 18f433a306f8efd3854067476b1c0961ef184883ebfe1fbf6c8bf77981f9141e60117a01e0b684727890d6fba6d173523a643bdb18ef621fe8b4e679cfddf7a3
MISC metadata.xml 419 BLAKE2B 5a559b50428f6425568dfbae01bce3ada0905cbea24542e75122f1f3fce9e04cec6861f4d662515c7efa8c15a5b2347a83af5a2ea38326c069f9253436e7199e SHA512 559911ed37cd63368b2783fd6d65aa9b5fecc7b58422978f9d86b32eb8f50275f6b52a910ea4c73ef2ef3d081373862eff8a8e0e4098bd83c6b1cf4f06cd1af0
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.7.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.7.ebuild
new file mode 100644
index 000000000000..fc8372837089
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest