summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
commit4968fd889f69d50cfcab1ffa12e56bdf476d9939 (patch)
treeb7b79ef2705cb29f73763bce76d98b1a8ceb667d /dev-python/sphinxcontrib-qthelp
parentd3ae3ea75073c53ed5f3a4418e76383436bb0f58 (diff)
gentoo auto-resync : 21:07:2024 - 12:30:10
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.8.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index 336dbad34552..645f11079e6f 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_qthelp-1.0.7.tar.gz 16685 BLAKE2B dbe4518134f31f9283a1de4a9f7c1b1fd59e3c639923dd5a84fe1c60323f8c0fbf31942ab51724241bf8865b78c5c83bc7c2187d7209b1c55027245cae2bd271 SHA512 fa11be5f663a0784a59ee18deaa8d497eeb4d5311fd86f75d48f40b70d8c0c868bd8625a001da274379d2b3412447abd810cb44af42f8a252cbcc31c400884c9
+DIST sphinxcontrib_qthelp-1.0.8.tar.gz 16778 BLAKE2B 71c0639f526e3a83bb5c47706e0073234a40691d22337cb41920f612fdd2798731b6d84cde2744e24e545c9d23559a48cc94ecdf49f887404370c3ef3f698756 SHA512 d3bde9e5e8ace4f58fc76bea22fdd7740a503f46a671f52f836039cd85f62733187b87395669bb2566de451c4de253725316ff97ca3c910b8dd31149c3c80331
EBUILD sphinxcontrib-qthelp-1.0.7.ebuild 759 BLAKE2B 8c4b3c8e3f70e81412b12f89e132546fdd99c8139c7b5ba3975c3cae86cb2475423d36b17bda36b181a954889a50bc9e1ca8b1e5f96691dc78e88b450540c60d SHA512 c1aa152279f151bd88d1a7a3868b00aeae6e03c93325740b5f25e4545a5ffdfcfdb3c386289fdca3e3142b9e8855072871e704380acd3527b6c1324408812413
+EBUILD sphinxcontrib-qthelp-1.0.8.ebuild 775 BLAKE2B 8833fd30fa0193dae8a7dcae66d20bcdf09477c542d70f9d2ca324cf44c9ffe289ad959e9c3984d5783ff28ac33e1cf792576d2d586f227d8c93a7446e0a7ea8 SHA512 c9ab5e4a239d5802b78ab0fd0e6e6998f147df73c10e3610f8d29ca29ee18134134d8e2b625d59c417df72b6e8a2297df406cf8b0e8a3a2c46dc148db0214377
MISC metadata.xml 419 BLAKE2B 5a559b50428f6425568dfbae01bce3ada0905cbea24542e75122f1f3fce9e04cec6861f4d662515c7efa8c15a5b2347a83af5a2ea38326c069f9253436e7199e SHA512 559911ed37cd63368b2783fd6d65aa9b5fecc7b58422978f9d86b32eb8f50275f6b52a910ea4c73ef2ef3d081373862eff8a8e0e4098bd83c6b1cf4f06cd1af0
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.8.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.8.ebuild
new file mode 100644
index 000000000000..b9254b35efa7
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_tests pytest