summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 03:19:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 03:19:49 +0100
commit37c470b10802509995e7ae6a6886506f79540dd8 (patch)
tree96943f8a8b2db8bfcb722f6fffe0f345edfdd52e /dev-python/sphinxcontrib-qthelp
parent63a4617476a3b084928b38d816b9ed6e196d62f5 (diff)
gentoo auto-resync : 30:05:2023 - 03:19:49
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3-r2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index 6ef8c249e0c6..da165caa9d06 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-qthelp-1.0.3.tar.gz 21658 BLAKE2B 7a82e8941d49836cf3e64aabe05ba65b34596f7ba0287b4dc7ed2c5940f6944d1853790d1d52637b03d934effbba8fc5094089e2924322cf1b373432c60bce6a SHA512 29f77e4b3f1a4868c2a34dbd853415e5d813f482cd23b982aeed42d53acba09b896d77ba930c34cce8af043bb7d64a19acff610430e942038d95a410b6e0b5fa
EBUILD sphinxcontrib-qthelp-1.0.3-r1.ebuild 942 BLAKE2B 7fe5defdccf16789c38613a85de23610c48bec9403cb52fcec532830ff985f96ef84544329c618d2855bf2347942deab77c38880f43e90364bff4e0f54a8958f SHA512 60787a0bfd77dd80c55fc6bc2fa8c9b2a348bf8b12faf52e0347447df78fe3800cabb508fc722fb3b83e2c3b8d4412dd15506c81ec6270d1877484a506219dc9
+EBUILD sphinxcontrib-qthelp-1.0.3-r2.ebuild 1194 BLAKE2B 4d75c4db99d096a020c60587f40c56d4fa37d93b1b5dd23c4631ec6fb7c85575d0f3f7c7ba40af7b30f6a4cf25284f73514b5b709f40c307dd947d4f40ac659c SHA512 1c65a6915caec78abedd42efd7c6c246943a54588f4b4bbf9250c9b7dc687d13b557b705eb1a0024db1f6afb9591cbe6377cb5f1446eb80b5349d53db9daaf68
MISC metadata.xml 419 BLAKE2B 5a559b50428f6425568dfbae01bce3ada0905cbea24542e75122f1f3fce9e04cec6861f4d662515c7efa8c15a5b2347a83af5a2ea38326c069f9253436e7199e SHA512 559911ed37cd63368b2783fd6d65aa9b5fecc7b58422978f9d86b32eb8f50275f6b52a910ea4c73ef2ef3d081373862eff8a8e0e4098bd83c6b1cf4f06cd1af0
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3-r2.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..ae6e7514abb1
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # This is already fixed in upstream, remove it on next version bump,
+ # see https://github.com/sphinx-doc/sphinxcontrib-qthelp/pull/14
+ sed -i 's/.text()/.read_text()/' tests/test_qthelp.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}