summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-programoutput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/sphinxcontrib-programoutput
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/sphinxcontrib-programoutput')
-rw-r--r--dev-python/sphinxcontrib-programoutput/Manifest2
-rw-r--r--dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-programoutput/Manifest b/dev-python/sphinxcontrib-programoutput/Manifest
index 13ac6c534e6c..7781114a6fa4 100644
--- a/dev-python/sphinxcontrib-programoutput/Manifest
+++ b/dev-python/sphinxcontrib-programoutput/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-programoutput-0.16.tar.gz 23714 BLAKE2B 1e5136faa89a2f303008fb0e24f99f544464d30f5c0c072db4e2e25cb30bfc3cd4af6157f6c8dc7ddfaffd8f6587435c5947b6981c34daf2d6029736fdc22870 SHA512 6003b8ce43ed468b01f6bda02c6f58c0518b38c43a75f1ed0869dd8df2ee215310246b7feeba90f213547644c1bdb0164cf1f44f44879ac054dcbd6d6f48a69e
+DIST sphinxcontrib-programoutput-0.17.tar.gz 24067 BLAKE2B 07687a221aa9be1e02629b2961b49eace217631a1298337f77a01986c3c6444a50069a8a8b9c96ca224895ae0f9490158a720519fdf3fb544e9d3e513282eb36 SHA512 cbb564830b8a627de6ecfa83fcc235d7dd7981e191ab3cada66a74d79a5bb2ec0a993eb8ae6249db553dc1814eae98891ea285f2c3cf5e745eabce7b8647b0c4
EBUILD sphinxcontrib-programoutput-0.16.ebuild 813 BLAKE2B 205d7daa5d9a412c84fe21dc932b03af9e9e9dde260801cd79ff071465ff43c0dc4cf67ad031310ab0d8f633f1a167cbb35e94a0580f103a5b98e979f15ed6ec SHA512 3f9339e16ca995b5a2d48af75f8a1f284978e0e0cae1f44035c25a5608aa0a9e15d637bd59f6303172c2f2390e3aa29d64583ee5fd2e29e02f022719d75f951b
+EBUILD sphinxcontrib-programoutput-0.17.ebuild 807 BLAKE2B b36518f095a1ae2b545a95ac4e0a167b02c417dff3f21e2cb19404ebdf8db0c09f2dc4f51e80c454318e26b261bd05207dda5cac129f914813908e29cfcf3c5a SHA512 18840b71e107733a543a84f1e7ec053684b44b50dc4e2b399a05f102442464354da91abfd015ba97dd691dc7da14690b193b6e70052078aa458fd5d49e74a2e8
MISC metadata.xml 1356 BLAKE2B 26ce7a37f737618f8788ee73f94f25cdbf5063044ac9014235f907932184168912a75c4c9f08cdace99522b2d8f157bbce8da79c7e3a55953d4692716c738849 SHA512 1f950132a2e93fe93bebcec0146fd343548b2ceb2f4d2cb99ac4e4afe428282e81b87ebdec77ae8191d51f35385ada447939a9d92f0b8e3c36af1b4fab0cedd2
diff --git a/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild
new file mode 100644
index 000000000000..b08129d07d47
--- /dev/null
+++ b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to sphinx to include program output"
+HOMEPAGE="
+ https://github.com/NextThought/sphinxcontrib-programoutput/
+ https://pypi.org/project/sphinxcontrib-programoutput/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}