summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
commitb43ae231a57eccda208f33c4343d956e7f2590f5 (patch)
tree8871b66b51dfb514ef803c4eaf3d1f2cb57c4ee1 /dev-python/sphinxcontrib-plantuml
parent7e84f2c47ae7a0e8b76fc3080b1c7ee8487ee76b (diff)
gentoo auto-resync : 31:10:2023 - 21:49:19
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
index 3188a8fe3b32..955b92998d39 100644
--- a/dev-python/sphinxcontrib-plantuml/Manifest
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib-plantuml-0.25.gh.tar.gz 18871 BLAKE2B 563cedb9c67303b08e71019f5ca21385a7ef6fd65b07eed01710c83776742868a18aa01346c2dcb7c9121693ec15f9181c610bd39432042812c891423dd0d3f8 SHA512 1f04ccfd1f8cedea22a0bd8d445e298d461c253d75f92a757c55ae013fa5043327312021f4915a15e522a5409d92217ac76865e7a520512c190ba3e6e5642f08
DIST sphinxcontrib-plantuml-0.26.gh.tar.gz 19112 BLAKE2B 65d4cca560cbc52271f22cfd479937b872d8bd58f72ac778aab873b5528312ccacc368328f65b29e437445080b9ca65a835019fe5cba38aac7488c5b3e03a6d9 SHA512 1ec004012d4eaeda0f0299206b6cbc1cbd246f378123d067912baf5b2f9c10ecffa4e27778d34db89dde84eff183fbeff35793420971cb94f42fa416af37786f
+DIST sphinxcontrib-plantuml-0.27.gh.tar.gz 19268 BLAKE2B d74d85da40a9c17eb6d73bfd2890af4f4260b11001bba4f3001d84f2f9b53597c2148c14af5a853ab3c0d3a760435a3475c6bc69748c9522f66b5f1c5e01d7b2 SHA512 acf648bc83647317d717c7f69026f20cc87066e26c409daaf14ec35e874f53ba324d1b2325b82987bc54f8224293113997bbfeca78b9f14c1704ff108e083faf
EBUILD sphinxcontrib-plantuml-0.25.ebuild 964 BLAKE2B 50f537411257ebefb08d3c4a5707ebb48b7f91bb9f7e68c1857de1b0225978f2ef9b6eecc2bb7009670e7249b6eb9aaf9a496f8400634654aa91656b3578f4e4 SHA512 4b843cf28faadb7b1cf4f7df51a9d5b01b7ca0e90cb774bde4038b7b4534151eff26ce9000be214e3cb0ad9616d64295f717705da9ac7141a74030983198104b
EBUILD sphinxcontrib-plantuml-0.26.ebuild 1012 BLAKE2B 39d337d3b92e5f73a07fe0302bcd8415bf673f32389082c4ac4d13c9e31377b74a7a5252d996f6968f5f16071af38e2b04203f30af9dfef579ac1e90e38f0828 SHA512 02bb72700675fbf27d566b4a07a1d48e8e622fda42ec413cc2c077fed18e7d96d7e62dae425ce5f5db9db3b50c7a50532ffa8ce267982f26601676d7c8e27426
+EBUILD sphinxcontrib-plantuml-0.27.ebuild 1013 BLAKE2B e4dd99bc2d85ea428677349a039af860ebffb61abede2d74927cef4b86fe59e190c2040a14c9dbac45ee3a552fcb97a4a83710b0c19ba1915d06410ff062ca4e SHA512 1161ba766abdb66ac2630d5d33991dd970eb2ce2a9d0f11df2917ad243868cd41cd5e3de7ac0411056c0d9acc82e7f071d7ee68f44b2376b3ce682148c15a454
MISC metadata.xml 419 BLAKE2B 05ba888453b1a19e83a8d21a5b0cc2a5a24482434b44c0f3bd4c75c99004523f6397a7a32811a336c15449ea86f1736e5a940d240d19f3956a176fce3881378d SHA512 6d8c4c646e7d84771a7ac7889650c06a0efcaa708d5e009df323f4d8ee591c75d864811ba10dde72b84f40359092302225a93d8de374da8d52033163356d6f46
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
new file mode 100644
index 000000000000..d4636449c967
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}