summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
commit3648761f2708fcf5662ea1b9585f594c36eefc30 (patch)
tree7b8af3caaff06cdddb5c39ec135ecc908b62a139 /dev-python/sphinxcontrib-plantuml
parent4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (diff)
gentoo auto-resync : 15:08:2023 - 21:27:55
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest3
-rw-r--r--dev-python/sphinxcontrib-plantuml/metadata.xml13
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild42
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
new file mode 100644
index 000000000000..7f8e406be99a
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-plantuml-0.25.gh.tar.gz 18871 BLAKE2B 563cedb9c67303b08e71019f5ca21385a7ef6fd65b07eed01710c83776742868a18aa01346c2dcb7c9121693ec15f9181c610bd39432042812c891423dd0d3f8 SHA512 1f04ccfd1f8cedea22a0bd8d445e298d461c253d75f92a757c55ae013fa5043327312021f4915a15e522a5409d92217ac76865e7a520512c190ba3e6e5642f08
+EBUILD sphinxcontrib-plantuml-0.25.ebuild 964 BLAKE2B 50f537411257ebefb08d3c4a5707ebb48b7f91bb9f7e68c1857de1b0225978f2ef9b6eecc2bb7009670e7249b6eb9aaf9a496f8400634654aa91656b3578f4e4 SHA512 4b843cf28faadb7b1cf4f7df51a9d5b01b7ca0e90cb774bde4038b7b4534151eff26ce9000be214e3cb0ad9616d64295f717705da9ac7141a74030983198104b
+MISC metadata.xml 419 BLAKE2B 05ba888453b1a19e83a8d21a5b0cc2a5a24482434b44c0f3bd4c75c99004523f6397a7a32811a336c15449ea86f1736e5a940d240d19f3956a176fce3881378d SHA512 6d8c4c646e7d84771a7ac7889650c06a0efcaa708d5e009df323f4d8ee591c75d864811ba10dde72b84f40359092302225a93d8de374da8d52033163356d6f46
diff --git a/dev-python/sphinxcontrib-plantuml/metadata.xml b/dev-python/sphinxcontrib-plantuml/metadata.xml
new file mode 100644
index 000000000000..1aafd82825c1
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-plantuml</remote-id>
+ <remote-id type="github">sphinx-contrib/plantuml</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
new file mode 100644
index 000000000000..64208ead486a
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="https://github.com/sphinx-contrib/plantuml/"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}