summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-newsfeed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/sphinxcontrib-newsfeed
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/sphinxcontrib-newsfeed')
-rw-r--r--dev-python/sphinxcontrib-newsfeed/Manifest2
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild39
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild30
3 files changed, 40 insertions, 31 deletions
diff --git a/dev-python/sphinxcontrib-newsfeed/Manifest b/dev-python/sphinxcontrib-newsfeed/Manifest
index 02125422e144..bc886641505e 100644
--- a/dev-python/sphinxcontrib-newsfeed/Manifest
+++ b/dev-python/sphinxcontrib-newsfeed/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-newsfeed-0.1.4.tar.gz 10862 BLAKE2B 708c7a725ac36f54ea735953ba9d230b05da95147eabc91de9d610d3e02ec7d0d1ab8f5882d4e97327da425fc49e1b1a1753e011445ede859edd4f3cd5fb2a16 SHA512 96d9d0c15fca8b62f945bafc8f0eafa62df9c471f7510e2f153e47b66534e5f3041e5c01df772e6c35a9f09baa70064642f7f0fa43ccfd33dd64c2604494f2fc
-EBUILD sphinxcontrib-newsfeed-0.1.4.ebuild 791 BLAKE2B 3c0600f37d45c2294af5c82f45dd9bf8b4ff7335aacee2cb6dabc5c53b6920950dc83e2c1d9b6b54488984ffe8dd603977fc1fc92bf48ffad406c714b59332e7 SHA512 5723dcf718108ffa2216534e79625a14953e89e2a476f4a62a2d1a7456e5b80c63eba934c282241187cbe188d522935e9441a29fa61e383da057417c76333c51
+EBUILD sphinxcontrib-newsfeed-0.1.4-r1.ebuild 890 BLAKE2B 1ede8445e1a1c0f7555129889d11102879d9b3330c8739ba694b33315129e4517d0b4e22be6b38154f5d6c6725b356541766f61e6030049964568363354f4990 SHA512 10ed0c3987ff948e3c65d7cb7f870dd94f332f9c1a4a51032ab7c4ce662fea621e75dba1c67740ea7c90deee82ed13d6650cce7b540d07f77daac2d2796812f9
MISC metadata.xml 356 BLAKE2B a4173a4a59c1cf182ed79bc084ffa73f5f32444cfb6e3a23ad85abbe80e2145bceefe7941d7d2d624e9e1021cfc8ff92abc69d77372f5d5dec03cec6a4131fbb SHA512 c5dc66026235b76fa995f37bdb57a89883119eb23ffa09a06f60f496e6ed60cf06c58fab9bb1bb9efc0a516dc2af232600996db29db181d35ab98746c652aa15
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..f0df71c8b01e
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="News Feed extension for Sphinx"
+HOMEPAGE="
+ https://github.com/prometheusresearch/sphinxcontrib-newsfeed/
+ https://pypi.org/project/sphinxcontrib-newsfeed/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
deleted file mode 100644
index fce5769cc191..000000000000
--- a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="News Feed extension for Sphinx"
-HOMEPAGE="https://github.com/prometheusresearch/sphinxcontrib-newsfeed"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
- if use examples; then
- docinto examples
- dodoc -r demo/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}