summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-jsmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/sphinxcontrib-jsmath
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/sphinxcontrib-jsmath')
-rw-r--r--dev-python/sphinxcontrib-jsmath/Manifest3
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild30
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1.ebuild2
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/sphinxcontrib-jsmath/Manifest b/dev-python/sphinxcontrib-jsmath/Manifest
index 171769b504b0..84b52f11520d 100644
--- a/dev-python/sphinxcontrib-jsmath/Manifest
+++ b/dev-python/sphinxcontrib-jsmath/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-jsmath-1.0.1.tar.gz 5787 BLAKE2B 055ff298e11678d7d30975e4bef509ece0128be30ca0c5fd2be1323c2eb4fe92f861826ea5ddfcbd2d3e3a80535b374d2b1a13446c2604f3e448d5a8982b9881 SHA512 c1e6488f5c0ca4567c27ec7c597c9db321ac32ce354c4ad62fea534b2ae1c0acb183a921f46216bbc3891f14acfaac05ddf324b8fdaf99828df07bc91aa7e5c7
-EBUILD sphinxcontrib-jsmath-1.0.1.ebuild 748 BLAKE2B 1f13e7352899767e5f9f0b9642ca4db4e01692a8231600f09fe38f1cfaa70dc7124967260700cb2be3936bf17149c7ef86fa224459e5695adf6d24ef7292c2b3 SHA512 4c9b45cfb500b5d3132eae38ef56309cc839aa7c8747b35eb52bef49970623d07b38314641f3ee1014054321bea8b3f7fadb9479f3a682bf60d958c1b49e85ce
+EBUILD sphinxcontrib-jsmath-1.0.1-r1.ebuild 909 BLAKE2B d564c9dce3c2e72c103f8660357abf646e88ed2bbc2720ae4adc5bfae32e2789678c738d245c12b52a89e956b938794ba6f6a421b6e18fb78cd550f7f9ad2f8d SHA512 31c7169ea69834cdbfeb79b454b94eb71ae23660fcf6a92dd69f39478e34919f3c5389b782f03c4dd1f5b0d73cb8e4c71324c7dc2401e4499ca908dec981b741
+EBUILD sphinxcontrib-jsmath-1.0.1.ebuild 744 BLAKE2B 9047f24198c926b5a86aba973f56ebb838a7ed1d594bd44156b5c66898fc6580ed6c511544438a790466e5e329d69511cf18abac986a530e17430f4fd9dd9175 SHA512 0ca988c79dc08ea04730dbe9ae67fff0c44609eed96db1c5af85f561da2fec98fb7da6fcd885e02ec195ea9a816bc4b4f16b454f157d3bc7c70b9fb4a1acd100
MISC metadata.xml 323 BLAKE2B bae56c440e079dcb99602f6e513fb9bf5c2415292f4c058e9da93fca5c14e0048789b1f9c1000b4d83cc37bc08d2fb3008898c2417a819c1128d1efe19e46414 SHA512 03745eb2d0defdb73cfd778eb7ab217cd839f9f94ce7cc1ef70c75c326cc0ba94bbc745624f8adca19e9049a332ca57c0951b0249f8a21b95ef6015ed6f545d0
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..2c170df58fcc
--- /dev/null
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-jsmath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1.ebuild
index 35274be34180..8c62c214c8ce 100644
--- a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1.ebuild
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
RDEPEND=""
PDEPEND="