summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-httpexample
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/sphinxcontrib-httpexample
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/sphinxcontrib-httpexample')
-rw-r--r--dev-python/sphinxcontrib-httpexample/Manifest3
-rw-r--r--dev-python/sphinxcontrib-httpexample/metadata.xml16
-rw-r--r--dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild44
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpexample/Manifest b/dev-python/sphinxcontrib-httpexample/Manifest
new file mode 100644
index 000000000000..6113da6f0521
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-httpexample-0.10.3.tar.gz 30489 BLAKE2B 1100f28398d0d23559fb7ebea8263be5da6f2db09e9d5f48513d80d2cd580d2ff436df84b532eba8fb0c30eb3787a86f57f75750aeb0857b52af09885ba9a124 SHA512 de776f20e566a5b2ec4fcbad82d2ac39988ccf651a14d38d353dfd9cda7c15289acbb41db56df9189e42c2637bfd70fd4915d19d4ee718ddd4de476ddc34151f
+EBUILD sphinxcontrib-httpexample-0.10.3.ebuild 1115 BLAKE2B e0ab292866364fec136fbc8e71a85d51e338a0f603bab1f57b6d95a59036884f7aab1041b05f7636d62bfa91fdfaeafd08b668c820a80eb0afe96f4bb1e86bc3 SHA512 0af0f77ca785c6a4bb9ea0cabc913c31abb1a89a076e72acf55eca2dadeefb0227369b62cdb3ac8afb11b42dad4f4709d867b235a14be6a42e225d5bbf38414d
+MISC metadata.xml 488 BLAKE2B e6597d8c074fbd398a11ba571a37a5b38d8c9de175622a706ff04d6a1d7933c9196b3ce4ae1c8c2a843f44333de7b22ec8bdaa429f46a2134bd8e019a76dc6ca SHA512 3bdb4e01cbf129f1cccb57c52cb7f2f15dd9977b77a625bf91c6a4fbd7807c101c45dfc5d516e1a91b66284871265748e54cb19bb18fb68e44661272af008862
diff --git a/dev-python/sphinxcontrib-httpexample/metadata.xml b/dev-python/sphinxcontrib-httpexample/metadata.xml
new file mode 100644
index 000000000000..39ac3a9a9590
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>vpayno+gentoo@gmail.com</email>
+ <name>Victor Payno</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
new file mode 100644
index 000000000000..62cfbf4fe443
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
+HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
+SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/snapshottest[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:pytest-runner::" -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}