summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-httpdomain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-09 12:18:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-09 12:18:21 +0000
commit83c424cc446967ca87809e13c2ef264eebce79f8 (patch)
treebce1c3a7e1f36095b5a4956a97e7ec63d3414d41 /dev-python/sphinxcontrib-httpdomain
parent92ed25ce2ff461f502de1dd96ab0accd683b69d2 (diff)
gentoo auto-resync : 09:01:2023 - 12:18:20
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest2
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.8.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
index 224239820a18..551634573937 100644
--- a/dev-python/sphinxcontrib-httpdomain/Manifest
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-httpdomain-1.8.0.gh.tar.gz 38228 BLAKE2B 46cbe5ef0689777ef560c167c49af5830e38c7efa3a536dd36702114eb87f3c0f2f1c0c9de808738ef081e09c7d47754bc49a039b04184696ee4389acbf18454 SHA512 64d916d58282e94a4fa2b2d0e8abad5c50106b739e6e15015d347af339f517c2c7457c9bc8dc74258cfc371910d1a02b582a2c94f6f98c195a366f68c5b108c4
+DIST sphinxcontrib-httpdomain-1.8.1.gh.tar.gz 41281 BLAKE2B 9ba157b1ed9494426226a8231d5a3cea420121722e5b4891049b76da567a917aebd8f2eac2c7a3ea899517fb4c64a6d0f1c50eb872fbd24418c464433a795c69 SHA512 ba0ba8d695302acedb3d51c3218748dfe25b756e8ba2eed4d8bbe012f16d09aaf822bbc93e0d6a32d3836b20345df2df7d675317aa96a802e7daef7fee792475
EBUILD sphinxcontrib-httpdomain-1.8.0-r1.ebuild 1043 BLAKE2B 93fa6c355103369b145f223881c61dc45b3532539c7e5a590025dd1dfe95ef9f5f4f48aef7f909ef7a7f43d6a0c2ce326029535edfa79220592ea18ed156884d SHA512 cb60047e66bb015070aeb16721aa3d87c8fbf46bb3510909b541523d796fed8bfef88af51815322fcc055e24bb77fe748bed0b7b18fea3c84371d7ecb337e3c1
+EBUILD sphinxcontrib-httpdomain-1.8.1.ebuild 1055 BLAKE2B 03aa27fa6c894e16d7039123079cce74c314ab1c53db17eb7c1371edfb73e8a58ddfdc94710af978dbdace645c9f917e83c556d635aa651cf48a55fbf64140b6 SHA512 336481ec98ddb39158974f52318698e04577fd43806d1e4de2e05b11b3afeef46bbbccc5321f1787656e2054349d8912e521b662fbffaa1d0394ab12141c24a6
MISC metadata.xml 417 BLAKE2B ecd20ec2d0b0f8dd3cc1ada969a171268f068f60dc698d644de42e2088f58cc66da59a73c735371d95a22d65a5699a9082e452605ab4d7e4a793d9311aed4a82 SHA512 b92a4542db033a1291b2983539597e651853a4faac6f8144796f59d13a7d75186f96a31c17dda30e280d246cd754a7696c1d1e6b330bbded25a23bb901ed3870
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.8.1.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.8.1.ebuild
new file mode 100644
index 000000000000..34c9095f95f6
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx domain for documenting HTTP APIs"
+HOMEPAGE="
+ https://pypi.org/project/sphinxcontrib-httpdomain/
+ https://github.com/sphinx-contrib/httpdomain/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/httpdomain/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/httpdomain-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/test
+}