summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-httpdomain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinxcontrib-httpdomain
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest5
-rw-r--r--dev-python/sphinxcontrib-httpdomain/metadata.xml12
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild21
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild27
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
new file mode 100644
index 000000000000..75d3f452ca33
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -0,0 +1,5 @@
+DIST sphinxcontrib-httpdomain-1.4.0.tar.gz 12192 BLAKE2B e4250a3814448d87255a6cef4fafb9be86bec1d7670fd30d2988cdc0c8d6db67fd18a1e9e02588754bd03ae7261806ce1d79d7bb8d94f47f2e2086a6897a67cb SHA512 85d4d0898a1703a1742755814200253b875795b5f267b08adb00c7d8d7c15c434718ce0f93656e7b698df89c958a9f6f3f3403bdc6d08f6df322fd80371f1d70
+DIST sphinxcontrib-httpdomain-1.5.0.tar.gz 13981 BLAKE2B ca08a5cdc22d9898c6972ce8b7585fc4f185e3a0c8e49302bfafbfc88b4bb69d9d3deaf15cca2dfcd2f218199f509023aeb542129fea2003cecb2e8ef8215fd4 SHA512 e393690314cb7a7b81207ee42826eb5360ca6cfa8ad1b57c9a8dd5897ed1ed97bad4a46d8348aad9d5f6b6145e5456af629b14973ad2561d5b90b2f8dbf2163a
+EBUILD sphinxcontrib-httpdomain-1.4.0.ebuild 635 BLAKE2B 7ff1482e4a3cdd2b3ce688f204df3b2004fbdaa5fe2df38e44b5736df7c6099488db31c0687663ae4db4de48c94dd9006a5ae57664fa95d551026e091cdf9c06 SHA512 6f6d76770211508f9f2ea5a8a31bde0b238cd1c1644415b6e982bd85bb884703ca45a463eac2fa2108e5f359f7123f8984f163a2a7e203baa0b6471d6d5b60db
+EBUILD sphinxcontrib-httpdomain-1.5.0.ebuild 811 BLAKE2B f1738bab2b5bd8d86d541f5780315fa94d8d2938355c3fee91dea7ebefc0f7f11d9bdc856746fc514974bc6f7dd28213cc2e0a4261c2d28956165471abb8a8cc SHA512 7a33707db9ef577791add8150af8f5ce767cee6908e4d05ff71f8ef85443148a6107ac71a2d8325c3a267c17a5caf11c1770e249a6df79e89409c354b98b678b
+MISC metadata.xml 407 BLAKE2B cf0e92bcd492b79892ebc97b7639c016b4d1853a87bed8fcd1e367a9f6cbadce01015895d22011425aba76a4895b245bee0e5536fc959224a6bed08daef74a88 SHA512 155696e449933084fbe56dd900e15d17e12d52d6af29eb4fcb6c05ddfe8c6fa716974fa27085c34ae2e1af0d1739dba2616eb12092c606b2645f2008e51d64a3
diff --git a/dev-python/sphinxcontrib-httpdomain/metadata.xml b/dev-python/sphinxcontrib-httpdomain/metadata.xml
new file mode 100644
index 000000000000..592df77578dc
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-httpdomain</remote-id>
+ <remote-id type="bitbucket">birkenfeld/sphinx-contrib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
new file mode 100644
index 000000000000..6ca21707ccec
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib/
+ https://sphinxcontrib-httpdomain.readthedocs.io/en/stable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild
new file mode 100644
index 000000000000..632c15f40f81
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib/
+ https://sphinxcontrib-httpdomain.readthedocs.io/en/stable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}