summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/sphinxcontrib-htmlhelp
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index 15bca69ab0f9..12d09b6c1b43 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib_htmlhelp-2.0.5.tar.gz 21925 BLAKE2B ba023e53c14b5427b09a9608cfc45ccdf932d4c27cce40932088fadb127ebfe50d7b2639513589469facf108fdc748e0f07195766e6e4bc67d26c50d00a2bf75 SHA512 537ef6a1a32863728a6324fcd50f9374e4f488ed7ed112f9f0ceb9e4488637f502280dda21835e8d63c6b6297d2a3db3032c3f307dce5948b516f293d07b9711
DIST sphinxcontrib_htmlhelp-2.0.6.tar.gz 21957 BLAKE2B 44b03832d8b89978062028be32a1253f2d5f2134b83f7e95fc685ab669ae3b4131dbad452e49d84cef56993a701f1cc1fbf1f50583fdc114eed7a05ad261c5ac SHA512 842194261315b35c470dee36ea7945b73dd08338f2b86d542b3a21d1cb900a2fbe0ba8ec2412589b4c8993b71d88b0e4fcfb0e3316db61c8ba2989811d3e073e
+DIST sphinxcontrib_htmlhelp-2.1.0.tar.gz 22617 BLAKE2B c9c97e4b879de3c4220795d6356925e70f09c6705740fafe609d2e1c02585c2f86a00e985969e60dd100bd26408a910d78e5537317d8e101e227b633bd2292c1 SHA512 9aa2650ed27712a94de6ea16954db952db9c4a0c5f509aba42e33c69ba46f7069e9ee01c09a31e531fd096882c0248cf72334404d717a9f35aafc22e3976530e
EBUILD sphinxcontrib-htmlhelp-2.0.5.ebuild 759 BLAKE2B d6a931be7d09ce83d23f545e779887fc70705aa6920dc0003fc0da4ed48d8e627302d17a36b9ef82c5d0633cebb919c3fcb796d2361dc94da9e52b795ab2b1e6 SHA512 c020f704eb46156a9e77e56a1562b99216bd3a33ace820c2edebf492081a41dd9f26ad5baf4224cb8304efea94b62c28212138f397c6393e505e60649d87f315
EBUILD sphinxcontrib-htmlhelp-2.0.6.ebuild 767 BLAKE2B 81fb51de2156d11bb7e4c10c6c88866d2d3b34f02d6bcbe1aad8cdae8bbb47506da51e97f738fa551cf74751e8dd2ed384f5a685a94218b3573eeaeca0fee992 SHA512 ad0a2be2009c4b3e7201217e2b0844536a4319fe4d703e99f589d532a18070bded58096118b4b70b44344ad996419cc5a529788daa47135653c106cef85de676
+EBUILD sphinxcontrib-htmlhelp-2.1.0.ebuild 767 BLAKE2B 81fb51de2156d11bb7e4c10c6c88866d2d3b34f02d6bcbe1aad8cdae8bbb47506da51e97f738fa551cf74751e8dd2ed384f5a685a94218b3573eeaeca0fee992 SHA512 ad0a2be2009c4b3e7201217e2b0844536a4319fe4d703e99f589d532a18070bded58096118b4b70b44344ad996419cc5a529788daa47135653c106cef85de676
MISC metadata.xml 423 BLAKE2B 49685b4a452f9f05a9f385c7c1913c282bd0714e1c92e42347960bdfa29ae01ed4eba7f43e3d1b7241d6bca4ddf4f8d3e0a1d0820a8af5edb7caca934908ecdf SHA512 8f497fb7ea0724be086c8a564481cf4d46ecf048791f76ed5494a7b0c0f46bf5eaf46875f0695b9add2914430c78427a5a77113a5f379052922217b415bfdb50
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild
new file mode 100644
index 000000000000..85c62da13499
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest