summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-devhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
commitd087665a0d6764fc223d2f88a04db01d76af9cc0 (patch)
tree698510baa01e5c4c92f7867e40bed45acd5f4547 /dev-python/sphinxcontrib-devhelp
parentd8e832445899a9a8ba4d8dc6f61f5feca79a3b85 (diff)
gentoo auto-resync : 10:08:2023 - 09:32:05
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.4.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index ef88dda92601..d48497465af5 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-devhelp-1.0.2.tar.gz 17398 BLAKE2B fcf04148bc4a77963517d9011c20a6b77eee499f1a5dcd4a9631b4f415f80a9f7091b254f74ba2fbc9b7106dfb741dc839e14813e088d5a0802793ed457e95df SHA512 83b46eaf26df3932ea2136cfda1c0fca4fc08ce8bca564845b3efe5bb00d6c8c93991f4edd4913d4ec796e2d85bd2c7265adf28e98f42e8094daeb5ac11a0eb1
+DIST sphinxcontrib_devhelp-1.0.4.tar.gz 12324 BLAKE2B e8e7460259f48c7373fe97ee70a5c358a5df21233d165645a15ba72f3fb1fd7bc3fba367efd56b27ee5861b6bed6fd14f9e22acd08b345e70b5241b3366e2bff SHA512 c3f924695a269e2de148e7e969f9c23f85292186212914eb0f9f6068518aa144f4d843e6ce5a9a2b1114a0ccbd3660e7728b8f30c6c6f21c2f83a139fb1f2662
EBUILD sphinxcontrib-devhelp-1.0.2-r1.ebuild 946 BLAKE2B bb250e6654387b5abe5a4a0aee9028ffc66bb315fc0045a4997987e4659cee1b0492aa64dff4e564f65f1e077485a7c1c35549e7f9d1ae0776eed76153030b88 SHA512 ab430e131cacc6fd3ca071f01f479e791c77e11c3b51435542fb50958624d452f3a40db065759537d7a975eae7d6a328d37f646df28d2ba117691f38017a16a7
+EBUILD sphinxcontrib-devhelp-1.0.4.ebuild 725 BLAKE2B e3d4339e8f0eadd69f4d6c2a026bab7d01780f7d6eed016134eca091ec7cc0549c9a794d2bf35144a20f9c22692cbdc30752400b12709911079f4205a304113f SHA512 6ef19a2fe036d109029e62653e36d7410a5a3292364efc41af9a0be15e33d824851d6a2f1aea0fa6baab07bcd73c6e77f82546c64b26d715e2e552fc69c195b8
MISC metadata.xml 421 BLAKE2B 0149d4fd64eb705d8731df8aab1a95f29797e68db4cee2dc31b9c1e1cda44223d966e0ffbd1e5ec1b83952f18c3d9965d4d1d7df51fcf88d8549e30572b0ab91 SHA512 b4051429218926b1a0ea4cf02f48a1ed3014245baa2fc4704d4fff116234fa2a83cd8c229377faa8e2f613445df1391d292c77482c59bc5441289e7d92bb8dc7
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.4.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.4.ebuild
new file mode 100644
index 000000000000..382aae94df28
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp/
+ https://pypi.org/project/sphinxcontrib-devhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest