summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-devhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /dev-python/sphinxcontrib-devhelp
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index ab0d7247dbfd..f551caf8a375 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_devhelp-1.0.5.tar.gz 12343 BLAKE2B f9c46d07888eab1bddcecce3a862fe503a0187620768a40f360fa985dee9cfaaf8d28f03c6a08e0b174788639675ee715141287bd7bf04ff403459e9858e4f9c SHA512 4412f9711b981c8e3beaa9940c09d02c21dc5e303a0ab80ca401f4cc5444bd159070a065a20c0e6f721202c05d880f20244ca5ff32df5911c8a4ba3d00ed9121
+DIST sphinxcontrib_devhelp-1.0.6.tar.gz 12480 BLAKE2B 40fcbd13156cba5d904ee30e98284f0bc6f53e4dc2003cbeca6cb0189122d8b453ca7ab849570bbea615a2b0d4fc016b1ff6f72b2f8ec337b9424b4fc9ff8a57 SHA512 97ab48f4adc16140323220bd23447d74fdec1d223e64c06a325df9568436bbce31edf5b33103dc81e0eb937f7ac8328b012fce80d2d6fd995dc0f63e9fb15f77
EBUILD sphinxcontrib-devhelp-1.0.5.ebuild 717 BLAKE2B 05f1b161d650dd0cbec298d5ac9ed4280286daa6ce8c97391d970b356e7f0938f43090b37cd8ddf7c0a1307e296c3d91dbdbc7d8556364500df7cc5cd276d9a2 SHA512 85e3601dccf4a23d5b34bdd75eddd977c50eb6832233ca646ed33cc0f2915f124688993ff3ce7361a783cca69acb47169a8d511c5e8c316a36b68ded03d22fe5
+EBUILD sphinxcontrib-devhelp-1.0.6.ebuild 725 BLAKE2B 447732eb1b59e44c9c1f34f34202f8c58f9e9d4bac7125735e39270ac625d2b5983e5e26c3b043c080a79d1741aada1629775ee4c9940884f773b1968a84590f SHA512 8f3c691ed38e0cbb66e35c77c2f83687a4dd6d9921438d769e75b2e4ecf124565369f8a595f7383c34016fe5e9c0734a6e5f4007fcd0e080b66e48b793c5b660
MISC metadata.xml 421 BLAKE2B 0149d4fd64eb705d8731df8aab1a95f29797e68db4cee2dc31b9c1e1cda44223d966e0ffbd1e5ec1b83952f18c3d9965d4d1d7df51fcf88d8549e30572b0ab91 SHA512 b4051429218926b1a0ea4cf02f48a1ed3014245baa2fc4704d4fff116234fa2a83cd8c229377faa8e2f613445df1391d292c77482c59bc5441289e7d92bb8dc7
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild
new file mode 100644
index 000000000000..1b24268040b4
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp/
+ https://pypi.org/project/sphinxcontrib-devhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest