summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-cheeseshop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinxcontrib-cheeseshop
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-cheeseshop')
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/Manifest3
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/metadata.xml8
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-cheeseshop/Manifest b/dev-python/sphinxcontrib-cheeseshop/Manifest
new file mode 100644
index 000000000000..9de278817c43
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-cheeseshop-0.2.tar.gz 3568 BLAKE2B 1d3d8378cf5c1d13ba2ba3f9c47a8f2f7eeb4b48daa4c57e639c65101cd7440932e3f62bd112a87ae24bfc3578a1e4b227584d011cb05a0df5f699c05daae69a SHA512 5d6c88c0c43f37b94ebe6a2a62f795a6f7d5d6c407b808d6b21d54c1775fc4b5f22466c13e61adc16ac7973ba11e99a66da8650c869856f766e6bb3a6e99923b
+EBUILD sphinxcontrib-cheeseshop-0.2-r2.ebuild 748 BLAKE2B 92cfcf049efdcdc716c8cd7f480daa97be734c5e3d580d7b7cf23ed2d2ed82922b611899731c3a2dfc20c0caca7ea895d543557f7bd3ddf90a162404356c058a SHA512 8df85762fcb7d922f3e8bf3c8fdcbfb853f741c70a89d4f0a4eabc0b9c98626397d68cfd80c3e7b1ee2e443479bc2c255e15d28464b71b905ba206e04285a638
+MISC metadata.xml 294 BLAKE2B 333c8af299498ae2721ce4e5a588c5faa950265aa0e46524ad514244a16b2061d9fadff09a5cd163b331516efbd75ac93c3f18b1954c27c3f821d4834f28cd85 SHA512 d259bb77b24de727ee5fb0f978c99240bb97c15f31d61d33961b54254ded998f05fb3a318c2b734b4e251b90ec99942a599763bb3ef7a1a33e3defd2940a4ced
diff --git a/dev-python/sphinxcontrib-cheeseshop/metadata.xml b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
new file mode 100644
index 000000000000..0550855b51fd
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-cheeseshop</remote-id>
+ <remote-id type="bitbucket">birkenfeld/sphinx-contrib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild
new file mode 100644
index 000000000000..0dad495679ab
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed \
+ -e '5s/file/open/' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}