summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-blockdiag
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/sphinxcontrib-blockdiag
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/sphinxcontrib-blockdiag')
-rw-r--r--dev-python/sphinxcontrib-blockdiag/Manifest2
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/Manifest b/dev-python/sphinxcontrib-blockdiag/Manifest
index d68db1dea094..95c77a559285 100644
--- a/dev-python/sphinxcontrib-blockdiag/Manifest
+++ b/dev-python/sphinxcontrib-blockdiag/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib-blockdiag-1.5.5.tar.gz 12066 BLAKE2B 4913aa53b365a05db2962c81c3f15df748c3424c88dc70bb5c97325c92492852698246b2d644748fde46ccc9ac6535871036851798db6d9db5e9610c5ef58b45 SHA512 4c007e2c394bf90ff84a000cf44ec1d50b39286a32929c89a64320299a70f10e44da35d942e7bb8697a9d61eb6a551f74bd15349cf0b439369aaaf12d175635a
+DIST sphinxcontrib-blockdiag-2.0.0.tar.gz 11903 BLAKE2B 9301fe05ff936836e8e648a507b7e2e5fd8cada58252fd46b274a4bb3e6b51b00b7696ceee712d12bd590c40c5ae1235e0b532ef55ffc2e78b2986cdae64a0f2 SHA512 305ad9b27bbb44480c69139cc0ae9cd8e47c6ad95da5b14a964c703a17e62ab9b342ff567e8312e403549a794f6381fe4c4d444ccb7a8e41410d1a3754ffb3f1
EBUILD sphinxcontrib-blockdiag-1.5.5-r1.ebuild 923 BLAKE2B 29b6a166090519a8a6d7aa3f381661161429db8e5f912f0a92dcb669ad92b23c550097755ae57bf7024e23fd4b58f3dac496e9f973bb742fe75d083249afd816 SHA512 f5d13643c66e24c6095badf6eecc4072bfdbd41928b2042b901042818229ba21236fd4bb0de71ab6161a5031f861d008b839d1eea2c2b592892a47c52189d875
EBUILD sphinxcontrib-blockdiag-1.5.5-r2.ebuild 1332 BLAKE2B 1729c17b7f5be02cd93fe1c0ae8465e6c1f3467b880ee35abdbe0ba44a90d2a3bd68013cd514a4963a9fb67d8a30ca4271972e26c4a73f68dcda3855be017861 SHA512 8e5c0bba10fb943b1ce19e27563167d49b1b1b64152f89b8a9838fda452d57abd2eec66436e10d1d4514940a3b8f817ec5f51d13a902b9d63cad710ad0e60e58
EBUILD sphinxcontrib-blockdiag-1.5.5.ebuild 674 BLAKE2B 58d9d30ab0ac583c6414fb8a650bdc1bdd37ea55a942fba667cc0bdcd2618d842518c694636ef5d1a09990b36375c1e6ffcc68c68dea88f6d5e6e33ce50a31d7 SHA512 ac98f936ae0824a53ac52a3cbe87b10a67d44c938eef071ff2bcf3e8c9996d32b858acb4777adc39a0d730261dc35278479479fbffbf41176552373312235fb2
+EBUILD sphinxcontrib-blockdiag-2.0.0.ebuild 1177 BLAKE2B 2804127cc9373b38afc66c1591fb2ec886abf5be001f38d8b5fea57c8f1b0c6cf84708a5bce852648b97c6c9ed0e0f5e0b0e25f25304d428a2ffd74c911567b2 SHA512 cb5f04267b91a778516a33c410a308120be5362dbea272f19869c0abe32d2d1a7a02e8c9e5d944f511ba98a85429c5427bcd5deb69e9316e1ca285c1dfffe698
MISC metadata.xml 416 BLAKE2B 4383283e64d8db0b5576f1defc62412b5c4f4003e5ac75a2755e79d3e2a53f6d7aff82741d6225d2c96f0e2d87df650d47110a31cc91362dee641a86c54b18da SHA512 10fc4ff78fce4beadf8f8b64cfcaf4b71f84c3f74d80bd7299055ef7c2a759bf8d8eaef841e464d72d3272d999fe20ebfbcd382f2025932eef474387e92be6e0
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild
new file mode 100644
index 000000000000..89d49e847b78
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ # Those tests are known-broken upstream
+ # https://github.com/blockdiag/sphinxcontrib-blockdiag/pull/11
+ rm tests/test_latex.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}