summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..775f0da1e163
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}