summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-bibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-25 15:54:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-25 15:54:35 +0100
commitd0bb3151c569ab6e40c84c177f43bff3c7ce4780 (patch)
tree0c543a2f299a437229bcd5db5c62697a41243689 /dev-python/sphinxcontrib-bibtex
parent601320c16301dbd7e8830e8c2ab7d6aef5b65abe (diff)
gentoo auto-resync : 25:08:2023 - 15:54:35
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest2
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index a61d79a4160d..d3d3922e5ad7 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-bibtex-2.5.0.tar.gz 113310 BLAKE2B 5bd39fccf33897bbbf8359a09f07a6e7146d4fb3c1ccb63ad96d3980cc4a256e0b9b37bbf6ceadf65eb01937741934e1f30841587eb6246b50774c81e8428998 SHA512 c99b4bf8cbc73e94e7e4486b4cb58de0dc928079b320ee7d7a473ee27b7f1e349a4765a30059aadc3fb0c6161940c6f2eaf7afdf5ac1c64ba73ed80fba5b5e45
+DIST sphinxcontrib-bibtex-2.6.0.tar.gz 116668 BLAKE2B e7ad397bccf362717f95df7a563838005b626b59a49e9b07933deed47061fd56fdd291c2d8f2848821d43f132720507bcf5664afb7c62b9c8ca8745b131ba6f9 SHA512 779948e228890d57e26f0b450a6b6b0f7311142bfe65636ca86f42610ae9a3713cee8a4b6f58dc4e12cebd2a87dd309685fb29fbd0dbdbad14f993cb241bf1d6
EBUILD sphinxcontrib-bibtex-2.5.0.ebuild 1096 BLAKE2B 1596b59e32bc0d6b5dc279e9d01b74425f7d5d4a4a207e62591fbf76be11390aa15ccae929877d3be49c2adb43fe7f43046246890c34475b8cb05d9b31cb39a1 SHA512 0c6341e52ce27b7f53fea5f6d147ef2c4a0be7a0f4a588fbc9d3d059b5b19a17ccdd7e660346def4bef29ef3dc22753eea306e50aafa216399e55a34e4363f9a
+EBUILD sphinxcontrib-bibtex-2.6.0.ebuild 1149 BLAKE2B 88533bcf0a557ebd950613eba6c6049dea6c39924d4663233cfdcc54e073da87e168e63bcadcc1e8349b12ca633fa1cfd2ee0d5e768241a25d5a55b81470c6e3 SHA512 3f16b46f211054ec4f12794c2e84ec8c504de2f776ceb576cd0006975abb0024657d72014e8eeb4e355f6982014e3447fd62483628fcc745f0a8ee6eaac8534b
MISC metadata.xml 539 BLAKE2B 9990d81362d6a2d5bb471fa2372b92d3ce4a4d08e57098dbe981b7a2320c46095e404a6077c5d5c57daf752c03bb4cb809461a05f11e1c2ecf771db201f8147c SHA512 421b99f9834ca4240a7959f99a8907379e0730b8c2ce608533ba4cafff3a8502738044675f0abed00f5f1cec195c18f5fd933404afff6f3c9b74c7cca02dba31
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.0.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.0.ebuild
new file mode 100644
index 000000000000..ea7f29444e5b
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/sphinxcontrib-bibtex/
+ https://pypi.org/project/sphinxcontrib-bibtex/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-docutils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # rinoh not packaged
+ test/test_citation_rinoh.py::test_citation_rinoh
+ test/test_citation_rinoh.py::test_citation_rinoh_multidoc
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ epytest
+}