summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-bibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
commit7ece7f3d3bcd0184dd8dfd6653464da80184963c (patch)
tree11ae8def15c0148aaf70c9bcfb86da05c82de6a1 /dev-python/sphinxcontrib-bibtex
parent6a4408b9bbd9fe61dc0966f587db94081fa5f52b (diff)
gentoo auto-resync : 11:01:2024 - 01:05:34
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest2
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index cd1120bbc317..13c57f054406 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-bibtex-2.6.1.tar.gz 117150 BLAKE2B 832fe8d16fd9311b5972127328edc506a0d4f2918c4ac1a4e56ce0530fa0c792db45f82c1801f48ff3299a52693a3041e9c2d6cbc4a17e864617ca58cfb6cd42 SHA512 9cf965bdfbcbc03b3104c9e7c5a730ac3e38c410554b7007485bd9aa0464663e26898537fa074c97951588a3e848a8a64e09d6c82bfc117ce4153da24de84fb5
+DIST sphinxcontrib-bibtex-2.6.2.tar.gz 117459 BLAKE2B 663521602282e360525354cc5ebffdba9e039f5d523774465f0b9318b39aa6429837164fc24e60d7646d204798a7b97d9defc176248b2793e7f7bbfeffc5c56a SHA512 a2b48306078de902cfdedbcafe94ea8aefcfff5285ec651fd1d0fe2c452818f9383ba486fb64e2ef4a294782445db2854bbdd158ab2aa1a49ed4adef85e9c82b
EBUILD sphinxcontrib-bibtex-2.6.1-r1.ebuild 1147 BLAKE2B 7bf4f82cca1e91b2e588d4c7d3b3883ef61d6295fb2f917989055a861138c6b04986b102b867dd146d1cff8deac4a6aec0260594569281106cded636ef7f89d6 SHA512 46d0e69eaf3463dd57748d28c1ddf0afbfd47a02f9ed432a1bf8e5beeb69f66393eb70f451b1937d56b69774d217ae0894b3435a032dfe0e5f4a41203f23fa44
+EBUILD sphinxcontrib-bibtex-2.6.2.ebuild 1147 BLAKE2B 78da8e79ba20b06067a5c88d6b135fe89169d4fdaba07a9bf3a96b1fab10a0d8f2522d167eed6b6cb81647db63d35ee8478ed9da476a6b660203785157e416c2 SHA512 d55eef0a9472ae866f0388128e5278cbef201aac5681923657f379f510c1167a4ba50b7a741760c9d6f6e86acb871a2e16a0be75ecc967a92d46059bca6b6c70
MISC metadata.xml 420 BLAKE2B d223bc2db261a665cfb0c89989462fa6fab9c2681d21d2631f1c1c4a602f4da47de5cae9fe1aca2c0ec8ab016e39a16043325cf1d69f7e965088753277fedef4 SHA512 73bd1bd6af050a30d01f6378b8c231fcc255d99839e4179e5ca9ef095c4f779062c2fbf03455d2fdd023e3c5104bf89d2281cdfbf33ef63ab49bd288174590eb
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.2.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.2.ebuild
new file mode 100644
index 000000000000..e5cec2c5aca6
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/sphinxcontrib-bibtex/
+ https://pypi.org/project/sphinxcontrib-bibtex/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-docutils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx-autoapi[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # rinoh not packaged
+ test/test_citation_rinoh.py::test_citation_rinoh
+ test/test_citation_rinoh.py::test_citation_rinoh_multidoc
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ epytest
+}