summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-bibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/sphinxcontrib-bibtex
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest2
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index a5c7e90cb4fa..230f647023d3 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-bibtex-2.0.0.tar.gz 135555 BLAKE2B 8a542ff7895a89a8dbf6b8ed1df3ab4e928b68ce86881819c1fbfafdda626c2e1106f5513832ee09248381c89f54f06d4d1b42f005b1f775b0fbe8962a0a0ff1 SHA512 bffd4cb1ea8d88b947b89f5bd1c55bbb8bbab8679f205216f87f932cc0170d2bbabfbe4ea8d32fb7c980826d3f7c4a20cd49c2fb36f288b5cdc4500ad9ff75cd
+DIST sphinxcontrib-bibtex-2.2.0.tar.gz 96027 BLAKE2B 77ca45e36f1730fa6992cfe41763a34e2a0bcdc99c520412591be3c219dcb7a8af240cc74d08c260548475b88b6cfba24b82e7bad2ab21b24c0e9cb62590792a SHA512 fa78d35f04825f841f757e2708d0ebbd3617a7bf20a893249eaee7e435ff2880ffc8bd23608356904ce41fc11d7fd49bab20f3da501d4a217593c52d99caebaa
EBUILD sphinxcontrib-bibtex-2.0.0.ebuild 717 BLAKE2B 68a5f0e8ff7ad027deab9d1c265b4368969891ff7a04f0afcb7d914d69afa6ce9cd225ab7f473cec0d054193bb30e9cb5afd5d12fce04a2bcc879166dbf90c5f SHA512 d6a3b48beac66e0d5ec41dfb7d0a84bf2117588043680785a2164ac7a4433b1a0d63c9a09a457ea7298cd0babbd050910fd2811cb4e46f5c7c1f4562ea3e8836
+EBUILD sphinxcontrib-bibtex-2.2.0.ebuild 792 BLAKE2B 0e3002f9741dfc7343d49bfe75fe2d8683ba5f1d7b3ff3a001c5fea45289c8c23f51925ab51bb6879ed88b3c6ab968ce9870168979f25336683291c6dd47a3a2 SHA512 7cd7b81c93902735eec977b1d815c9ba04f10cbb35b5ec40a9e75d5d248c9ac440700f5bd5289662cfea241a0a1aa1c272ebc2385bf41548cabc600b6e7729ae
MISC metadata.xml 530 BLAKE2B f1d70822ed84bb0da1bc7702416f944107b1d7812c853b5e4973d5c28c9722051860f0979f8f19abc23ec555cab46c046bb2264a1ad3ec6b4f422ae4b5408471 SHA512 c4bc4d4e3699247b24d4ad57cd88c1688bb46348c7b989b631b46d2313a0da380856e08bb311a39bad5fbce06680bff8753cf989a76691cc09092fc644db4574
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild
new file mode 100644
index 000000000000..3c3e2d33175d
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/oset[${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pybtex-docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_test() {
+ pytest -vv test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}