summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-bibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /dev-python/sphinxcontrib-bibtex
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest1
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index 729e6a3c2c77..af122fd17f60 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -3,5 +3,6 @@ DIST sphinxcontrib-bibtex-2.6.0.tar.gz 116668 BLAKE2B e7ad397bccf362717f95df7a56
DIST sphinxcontrib-bibtex-2.6.1.tar.gz 117150 BLAKE2B 832fe8d16fd9311b5972127328edc506a0d4f2918c4ac1a4e56ce0530fa0c792db45f82c1801f48ff3299a52693a3041e9c2d6cbc4a17e864617ca58cfb6cd42 SHA512 9cf965bdfbcbc03b3104c9e7c5a730ac3e38c410554b7007485bd9aa0464663e26898537fa074c97951588a3e848a8a64e09d6c82bfc117ce4153da24de84fb5
EBUILD sphinxcontrib-bibtex-2.5.0.ebuild 1096 BLAKE2B 1596b59e32bc0d6b5dc279e9d01b74425f7d5d4a4a207e62591fbf76be11390aa15ccae929877d3be49c2adb43fe7f43046246890c34475b8cb05d9b31cb39a1 SHA512 0c6341e52ce27b7f53fea5f6d147ef2c4a0be7a0f4a588fbc9d3d059b5b19a17ccdd7e660346def4bef29ef3dc22753eea306e50aafa216399e55a34e4363f9a
EBUILD sphinxcontrib-bibtex-2.6.0.ebuild 1149 BLAKE2B 88533bcf0a557ebd950613eba6c6049dea6c39924d4663233cfdcc54e073da87e168e63bcadcc1e8349b12ca633fa1cfd2ee0d5e768241a25d5a55b81470c6e3 SHA512 3f16b46f211054ec4f12794c2e84ec8c504de2f776ceb576cd0006975abb0024657d72014e8eeb4e355f6982014e3447fd62483628fcc745f0a8ee6eaac8534b
+EBUILD sphinxcontrib-bibtex-2.6.1-r1.ebuild 1094 BLAKE2B 0c6a6d8e4948a3fca495ce328098e6a9a2705670096fa1236ca93e5269dd29172841f238d3e1d6bd7ccfe7e3fe4fdebf435e0dc668460d59d3f2dbabc418b799 SHA512 67d35d338498ddcd8f2171fc656fe1e812af20a5ef6cac041e258a9b1056ce0e577c4bab62432da76a0e32568a2d1b9c71a18595126ba5e4010e4ba76d2f7f39
EBUILD sphinxcontrib-bibtex-2.6.1.ebuild 1149 BLAKE2B 88533bcf0a557ebd950613eba6c6049dea6c39924d4663233cfdcc54e073da87e168e63bcadcc1e8349b12ca633fa1cfd2ee0d5e768241a25d5a55b81470c6e3 SHA512 3f16b46f211054ec4f12794c2e84ec8c504de2f776ceb576cd0006975abb0024657d72014e8eeb4e355f6982014e3447fd62483628fcc745f0a8ee6eaac8534b
MISC metadata.xml 420 BLAKE2B d223bc2db261a665cfb0c89989462fa6fab9c2681d21d2631f1c1c4a602f4da47de5cae9fe1aca2c0ec8ab016e39a16043325cf1d69f7e965088753277fedef4 SHA512 73bd1bd6af050a30d01f6378b8c231fcc255d99839e4179e5ca9ef095c4f779062c2fbf03455d2fdd023e3c5104bf89d2281cdfbf33ef63ab49bd288174590eb
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..3e70af03cf4d
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.6.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/sphinxcontrib-bibtex/
+ https://pypi.org/project/sphinxcontrib-bibtex/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-docutils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # rinoh not packaged
+ test/test_citation_rinoh.py::test_citation_rinoh
+ test/test_citation_rinoh.py::test_citation_rinoh_multidoc
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ epytest
+}