summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-autoprogram
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/sphinxcontrib-autoprogram
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/sphinxcontrib-autoprogram')
-rw-r--r--dev-python/sphinxcontrib-autoprogram/Manifest4
-rw-r--r--dev-python/sphinxcontrib-autoprogram/metadata.xml1
-rw-r--r--dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild30
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/sphinxcontrib-autoprogram/Manifest b/dev-python/sphinxcontrib-autoprogram/Manifest
index f3775de314c8..ffbe66b796ba 100644
--- a/dev-python/sphinxcontrib-autoprogram/Manifest
+++ b/dev-python/sphinxcontrib-autoprogram/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-autoprogram-0.1.7.tar.gz 18663 BLAKE2B c1ad18df1c9ccb8fb1947ba7abbe2bc52fb531ce8142340b71bc063a6a758831d2a46913fb969f52791c3a86cb86a8eddd378c6403e1be4eb23ece2380386eea SHA512 df416759e9d6bfc69780f864bfd2c0fb847515df1d5416e4c7fb78ea0feb9cf0e360da457414a6bed5a56f69fd8ece3ccd2ed5af5fc1f56b40063765ff04f7a5
+DIST sphinxcontrib-autoprogram-0.1.8.tar.gz 18656 BLAKE2B a1334b0d9717f59ffb67c8a60e03b34c1fb0168cc86500ee14c06c44bef5bec1b484997d00be6586832e21e8a97662628636766558af9f79d40eb3da0ae21122 SHA512 a73d52a6195e3b637758b36f86afe07090bab09a655a86dbde3fefaee59f634c3fc880d436c3b14d9d7d4fb58f74765bd13457d0fc9192f1ffd4d654dc6efcd5
EBUILD sphinxcontrib-autoprogram-0.1.7.ebuild 665 BLAKE2B 981f76cf2ed6cb1babd3bbfb6ad05d2d06dacb6c9a2e9e4e6de3e89642d4e9dbc5c48628763d9cb6c8f3d7fecfab07b2542b3670a9a35176808300d45c439b44 SHA512 4749de0ba1a9f96eb23463e652f9fcd2e802d4e9a38375009fe209214e4175e00820c8d75da1758d673ebe2d9793b59f4546087259b7f55b799cda0f07da7634
-MISC metadata.xml 371 BLAKE2B 18613d832bd019781033faddd8b2f023387986820f3ead099562a15d324f930c5b1c66d9f7afddace013f8a80290c2b31948735a8cce989044c3e64bcc17c227 SHA512 2f1d4f8006eb4924bb570ab15b243d9ba9db0efa6dfda8e35209adec0d4dadce90044bf90f95fe140b60fb5e94c794c82080fe1c56dd028064e9f44d11441ccd
+EBUILD sphinxcontrib-autoprogram-0.1.8.ebuild 642 BLAKE2B c7b71816d178c24ce8d4777b57609f9fb5a4fcdf77575f63a9f0d7a9b6e850155a7964f7ee3106ea474f1c57f903dc1d8ac5d00c7beda9ee97d92827c018a855 SHA512 b4659558312eefa9c5e55970276ecaed3fcd3496cebb87cbfade9450797b9c92b611bd3bacf9cfa66c5be2699dfeed2cea1ace5fa8af1b37f1c88c8be7272753
+MISC metadata.xml 437 BLAKE2B 9e39af7803966fa76096217ad37df0ce8ff795bbfad2a20a0bc58485d4292626f7ad334c0e2918993f3c6a03a791c8f7ea7e4a3e68e75fd8bab3c5b4a7a00bd8 SHA512 7a3a8412639455ff004479bc6862312fdf17cde00905c4fc7a2eab839b6a26ad09facc879519b024d33d04ac62c16ed60e35719e89a7a75f3452ad55c0dc0dc5
diff --git a/dev-python/sphinxcontrib-autoprogram/metadata.xml b/dev-python/sphinxcontrib-autoprogram/metadata.xml
index cdb3abdab6ab..7fcb271774a0 100644
--- a/dev-python/sphinxcontrib-autoprogram/metadata.xml
+++ b/dev-python/sphinxcontrib-autoprogram/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">sphinx-contrib/autoprogram</remote-id>
<remote-id type="pypi">sphinxcontrib-autoprogram</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild
new file mode 100644
index 000000000000..9a6e63d88a0f
--- /dev/null
+++ b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Documenting CLI programs"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/autoprogram/
+ https://pypi.org/project/sphinxcontrib-autoprogram/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}