summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-autoprogram
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/sphinxcontrib-autoprogram
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/sphinxcontrib-autoprogram')
-rw-r--r--dev-python/sphinxcontrib-autoprogram/Manifest3
-rw-r--r--dev-python/sphinxcontrib-autoprogram/metadata.xml16
-rw-r--r--dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.7.ebuild28
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-autoprogram/Manifest b/dev-python/sphinxcontrib-autoprogram/Manifest
new file mode 100644
index 000000000000..eca694658cc0
--- /dev/null
+++ b/dev-python/sphinxcontrib-autoprogram/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-autoprogram-0.1.7.tar.gz 18663 BLAKE2B c1ad18df1c9ccb8fb1947ba7abbe2bc52fb531ce8142340b71bc063a6a758831d2a46913fb969f52791c3a86cb86a8eddd378c6403e1be4eb23ece2380386eea SHA512 df416759e9d6bfc69780f864bfd2c0fb847515df1d5416e4c7fb78ea0feb9cf0e360da457414a6bed5a56f69fd8ece3ccd2ed5af5fc1f56b40063765ff04f7a5
+EBUILD sphinxcontrib-autoprogram-0.1.7.ebuild 617 BLAKE2B ec74e3668f528b330f4f2c82156ec326236bbf7b62e3ccea9481a6320d668a94054b6569505aa300e7d3a16d4fbfb6e37fffdb5a80b42ab54f5f4b01c6c21f4e SHA512 90919cd3f04074906d832ab73fcdc00cd8f10f880bf227a383c6d2733fddf8e16462f5a2d468eba3c373b5c5e3e84a71390f7ed6ee21190594d23407524b2973
+MISC metadata.xml 517 BLAKE2B 30f784693dc9c70d2b64225ecfcc0921a6f9f6eb4d4f6585be086298b1192ac855b0da28eff18802f3ed7fa2365b63d4b3aa92c54892bed95e7ee775b834cfb9 SHA512 14ced1c6c870815eb3d5992743969a27bed4e31b427850366588a4818c972588cdfada0a87148b165dfb2a4fe7b70ba90af4ba7f9f38d2a4188846af82b8f7cb
diff --git a/dev-python/sphinxcontrib-autoprogram/metadata.xml b/dev-python/sphinxcontrib-autoprogram/metadata.xml
new file mode 100644
index 000000000000..98890bad775c
--- /dev/null
+++ b/dev-python/sphinxcontrib-autoprogram/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-autoprogram</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.7.ebuild b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.7.ebuild
new file mode 100644
index 000000000000..b539027a7f4d
--- /dev/null
+++ b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Documenting CLI programs"
+HOMEPAGE="https://github.com/sphinx-contrib/autoprogram"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc dev-python/sphinxcontrib-websupport
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}