summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinxcontrib-asyncio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest3
-rw-r--r--dev-python/sphinxcontrib-asyncio/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
new file mode 100644
index 000000000000..6c1fb271acf8
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
+EBUILD sphinxcontrib-asyncio-0.2.0-r2.ebuild 1010 BLAKE2B d2a0731729f305c6b8962531fa197266cd5579f54ffd606eb7ec0b6be49b9a2b1663f837d18468097f475a64b3d0ae60d39defafdcd718f8bc5f6cd0b095806e SHA512 cc67f66d60e132b77a70cd016cf685aa09d56d0a9aece980f5095c4e3e2e90300070b68f9733b53a728a79715eb344b05b63eac8d18e8af1311c26bfddc363e9
+MISC metadata.xml 372 BLAKE2B fc779af5274229957de772908e2a2fb9bc0cd75673af9ab88e4b6869164c75b7cca2fff4895beab62bbce984e93255b6578a6360621c5d0eefadcf49ae3f787f SHA512 63aeaf1b521f6c789128dc03be198ddcbfb6dc7e63fa6b24eef1cd23e9557d5de5f7c990514b95dd2b74634f47f3f5db89f233dfbbfb711527e51806bcd5a367
diff --git a/dev-python/sphinxcontrib-asyncio/metadata.xml b/dev-python/sphinxcontrib-asyncio/metadata.xml
new file mode 100644
index 000000000000..be0d1e129d10
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aio-libs/sphinxcontrib-asyncio</remote-id>
+ <remote-id type="pypi">sphinxcontrib-asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..ef4858611d7d
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install() {
+ rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
+ distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+ # clean up pth files bug #623852
+ find "${ED}" -name '*.pth' -delete || die
+}