summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/sphinxcontrib-asyncio
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest2
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild (renamed from dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild)12
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
index a54b073ae480..de75236fddc1 100644
--- a/dev-python/sphinxcontrib-asyncio/Manifest
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
-EBUILD sphinxcontrib-asyncio-0.2.0-r1.ebuild 1050 BLAKE2B 24f667c0a5b95384d7e97f5c8168f1a3600e6c910acc53f249ab9856337cc93f1fde0448a2f7d0177889ff4db0ae45263f2ff0baf7c4ecf86df24a8084df40ae SHA512 c9545013ef9c8060ca3607659d5f5231009e746ef05d42093e6688813442ea17e0992820f62134de2518ea2e80987241bc1eb87b24afc653e3c2e3d0acfa5119
+EBUILD sphinxcontrib-asyncio-0.2.0-r2.ebuild 1010 BLAKE2B d2a0731729f305c6b8962531fa197266cd5579f54ffd606eb7ec0b6be49b9a2b1663f837d18468097f475a64b3d0ae60d39defafdcd718f8bc5f6cd0b095806e SHA512 cc67f66d60e132b77a70cd016cf685aa09d56d0a9aece980f5095c4e3e2e90300070b68f9733b53a728a79715eb344b05b63eac8d18e8af1311c26bfddc363e9
MISC metadata.xml 479 BLAKE2B 71c78e4a7069091b9e6030f37e85bacb777bd9c23e560c4b76adb48ebf4cf0e1097ffc96fabe01c61dd82e9a19558076e8758717833dfea63c050a756ba81a5c SHA512 ea288acf888e29a1213e200599e7cc9528c99899edb613b6b77c80aa761cd0b0630837a9c1529fa8ca5e36935f263c8a37978b3afc0ea32cd8b5e3c1671dfaf5
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
index fe969fc8bbac..ef4858611d7d 100644
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,14 +26,14 @@ python_compile_all() {
use doc && emake -C docs html
}
+python_install() {
+ rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
+ distutils-r1_python_install --skip-build
+}
+
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
# clean up pth files bug #623852
find "${ED}" -name '*.pth' -delete || die
- # collision bug #625872
- _namespace_cleanup() {
- rm "${D%/}"$(python_get_sitedir)/sphinxcontrib/__init__.py || die
- }
- python_foreach_impl _namespace_cleanup
}