summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-applehelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /dev-python/sphinxcontrib-applehelp
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp')
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
index 276dcfc0a0de..02bca9a44fd4 100644
--- a/dev-python/sphinxcontrib-applehelp/Manifest
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_applehelp-1.0.7.tar.gz 19543 BLAKE2B c44cdb9403fc9272e5220f23b3ce6d9eb63f754b526b450d857f0260e92ab92e35bf814df40ba11186ae7bbd070516fdccf475c8777113393327c33afd42eb07 SHA512 8ab1e8ce73591a32c4d73d022ad87e003e6fba36bf4f670f7b9a6b213ed8f396506d8e2998182e19ec9c7ccf21e7d52b5de9b7a8ca0ed676738c4e10fbd738b2
+DIST sphinxcontrib_applehelp-1.0.8.tar.gz 19674 BLAKE2B f449cdc28cbf8374cdfa5bdacb501c3bfc8a4a93c855c220e66989d538f76653ddf4b81fb0534dd043771b60d0de01c9d3c30cecfb02cbb2fc0c0cd2320b377d SHA512 0afd38caf07e60b45b47e7e1cc8dea0d34578f7501a6000c6bc860454bb71d8c9d59c7b66ee39c173d635c1944735782762e713598d99dd4fefda51ccd1d74d3
EBUILD sphinxcontrib-applehelp-1.0.7.ebuild 719 BLAKE2B c890bcb63e6d9d71844106273b6e35f3cc6de055cea474b692739f291d4fbd2fb5ca2e518bd47c51a1dee5f20d8518cf68e6a2e353e5767c35eb958b9bccf967 SHA512 ea849d801e61ca703390d4ca9ce79a3deb63e3a0ed2e8981dda2a6a71634ce97d905159232f1d8063ad90da80c8166dd730f00cd46473592c29a10e736888048
+EBUILD sphinxcontrib-applehelp-1.0.8.ebuild 727 BLAKE2B 995c86dd70beaae61961a0bdfb211da8046b915d4697c68b278fe96d599008d3b0a9dc0182116934ec4c304b375295287f61607ec8508faa440675d291d5e191 SHA512 1ebe18ef6220bd909d0d5a7fd2a3f5c1a4993d3c9022d944d81bf89f5e7cb7cb954a0f797f448ba7e3575a9a6d864bb2b980a5f864e868c8c89d03713075e33f
MISC metadata.xml 425 BLAKE2B 69f933f9bbb268736b6d99ac9256c9b2a5eb53259e117a2e02dd5b2d284d83b947c9e58fee62f4b2bbf1446829f337319fdd4c1f703d6f6c84a4ca5799d141cf SHA512 76f9a4483e7899eff96173738d4c116988fbb64852a306359649dd882abbc6b574e685a7947e4636f517aeb4b4ff56a9f8f84d9aab8da63c45fcaced3ce1aa15
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild
new file mode 100644
index 000000000000..76a136b509fb
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp/
+ https://pypi.org/project/sphinxcontrib-applehelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest