summaryrefslogtreecommitdiff
path: root/dev-python/sphinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/sphinx
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/Manifest2
-rw-r--r--dev-python/sphinx/sphinx-3.5.2.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index c3320e470dae..5f88cf781caf 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,6 +1,8 @@
AUX sphinx-3.2.1-doc-link.patch 604 BLAKE2B f23f8f9a0a48b170e2b6daaeded1e65aebe830da463d4e30f2405b511cb72dde12767d0113b2d1efdce821c16837d700c71c60de38d20950ca5d6579f19a80ff SHA512 3088ba8768b4ba9e6a187e4c52fcc226efd5125fd01526b4a724504f4c445d69d6964fe79c1325ff7f58edcefc7f3489393ab085ea0458d94c44b186aa16e2f1
DIST Sphinx-3.4.3.tar.gz 5997116 BLAKE2B 73a488564d5889bfc6d7f6f797aa3b144b03cf5f086a4543c3f4b2a452b353f4d799b80a14a0d4118e227660b7f9367fe8f3a2e91f6127cdca489cf4fad215f3 SHA512 2e085e00c722f3aaf34552eefc3842daf5443f7b8a11afa850db1e31ad81d5ff7f579622b91f982b21708fa6379907bac4fe72d42dc05859a3f62c75298facaa
DIST Sphinx-3.5.1.tar.gz 5905170 BLAKE2B f374a65d66f404b2a7486c58a0e13e228e0de88985fed18cfa74e8219759af6afb1bb05cc10b6a8ed8ad7b413889b7282de7212010fe6d3bd30ce04fe9b59b9a SHA512 31a9253e30d5616c99161455fb61ab3b8298b5364d5eeb5c7b23466182913c99fea4cec14d088b6b64a530cbfb60d691ad093a6f6a0f9060f847f0b73d5e6b3f
+DIST Sphinx-3.5.2.tar.gz 5907358 BLAKE2B 59b2789d7f3cc34622f34c54b5d614be7fa22d9d61cbb6c096ac7efe8f011331f51af12986d505245a30c9583050ae8c012ac736cd8ff5234f528616999dc325 SHA512 97f1589726fe5bdf48b5bc8bfc53267fb4dfa2f21d5d9eefbd9bcc9ff5cc0c7846840b0fe5fcdd133d9735d402189d5b89202de4e462dce99a7653d6f1a86ff9
EBUILD sphinx-3.4.3.ebuild 4228 BLAKE2B 03956198ff8572f45558478db5d23e045c52ea99c6cc30344b9d9db119fb495b8948da092a922857c2089e388bdb7ddf5f2ced2dd4c3c865dad63779271743d1 SHA512 853b855364f0559bf63e8342d91a3dda21aa04d67c349108f86522a8968602b61e9a60fa6262a7af1e18ac50bdfcdb4e8283fac384c879eb087ff15998569cae
EBUILD sphinx-3.5.1.ebuild 4190 BLAKE2B 41227a347dde3aa2d5df18933961aea6db9eb2b70bc2af441d4743fb39472b0b9a40a2c9a89c774da60f54130e0374362fabd6dbb4306fc29e160f111c24073f SHA512 5051c57468f7f180a2513ce7445f61cb3012a239bf3989c5e6323b42f7c2349e5d0029b5c0f36112bbc9632b479be15269d805df10571ff4b8c32be495870e11
+EBUILD sphinx-3.5.2.ebuild 4190 BLAKE2B 41227a347dde3aa2d5df18933961aea6db9eb2b70bc2af441d4743fb39472b0b9a40a2c9a89c774da60f54130e0374362fabd6dbb4306fc29e160f111c24073f SHA512 5051c57468f7f180a2513ce7445f61cb3012a239bf3989c5e6323b42f7c2349e5d0029b5c0f36112bbc9632b479be15269d805df10571ff4b8c32be495870e11
MISC metadata.xml 567 BLAKE2B e99637c5c116e3b8b17bd92341271350eaab38d3e0c5918ba2921db1fa0abb4615a1903b9916f94f3951f8b22e2939d71c5fde97b6ae467bc80570bdfee3b13e SHA512 7f9edc2ab5d01da2d23630f1cca2a25cb727b8336b600b48934b205727876361c2cc5432772940d855a00766d190b3319dc397927b9218345dac226886e9cec4
diff --git a/dev-python/sphinx/sphinx-3.5.2.ebuild b/dev-python/sphinx/sphinx-3.5.2.ebuild
new file mode 100644
index 000000000000..86421550c2b5
--- /dev/null
+++ b/dev-python/sphinx/sphinx-3.5.2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinx"
+SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc latex test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
+ dev-python/imagesize[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typed-ast[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ latex? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+BDEPEND="
+ doc? (
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools[jpeg,png,svg]
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.1-doc-link.patch"
+)
+
+python_prepare_all() {
+ # disable internet access
+ sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+ doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # Generate the grammar. It will be caught by install somehow.
+ # Note that the tests usually do it for us. However, I don't want
+ # to trust USE=test really running all the tests, especially
+ # with FEATURES=test-fail-continue.
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
+ popd >/dev/null || die
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
+ local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
+
+ local deselect=(
+ # these tests require Internet access
+ tests/test_build_latex.py::test_latex_images
+ tests/test_build_linkcheck.py::test_defaults
+ tests/test_build_linkcheck.py::test_defaults_json
+ tests/test_build_linkcheck.py::test_anchors_ignored
+ )
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_ext_autodoc.py::test_autodoc_inherited_members_None
+ tests/test_ext_autodoc.py::test_automethod_for_builtin
+ tests/test_ext_autodoc.py::test_partialfunction
+ tests/test_ext_autodoc.py::test_autodoc_typed_instance_variables
+ tests/test_ext_autodoc.py::test_autodoc_typed_inherited_instance_variables
+ tests/test_ext_autodoc.py::test_cython
+ tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_subclass_of_generic_type
+ tests/test_ext_autodoc_autodata.py::test_autodata_type_comment
+ tests/test_ext_autodoc_autofunction.py::test_builtin_function
+ tests/test_ext_autodoc_autofunction.py::test_methoddescriptor
+ tests/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
+ tests/test_ext_autodoc_configs.py::test_autodoc_type_aliases
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module_skipped
+ tests/test_pycode_parser.py::test_annotated_assignment_py36
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests fail with ${EPYTHON}"
+}