summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/sphinx-testing
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest2
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild19
2 files changed, 5 insertions, 16 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
index 83d61e56b2c6..8a83eec8c753 100644
--- a/dev-python/sphinx-testing/Manifest
+++ b/dev-python/sphinx-testing/Manifest
@@ -1,3 +1,3 @@
DIST sphinx-testing-1.0.1.tar.gz 11513 BLAKE2B 46ede243507a0d90b2ad4b918deadb818491bb0ed15ce41886040c52650f9fd348ff57c03766fd1e7719bbb54726f8915e091cf94a5396da946102ca49fd07b2 SHA512 2d377c0c6fe8e34a463b35e96938507a3ca35fa06cd19a2682eb55825e1b88982a80a02ebb9a02a47f11ca5e8fe6a5b9e5c8114d955fa3b774e0148e82121818
-EBUILD sphinx-testing-1.0.1-r1.ebuild 830 BLAKE2B 9296c056734d9f5f9c7ae5f5ce38fc44e6ce5fc0af764d9112122dee4f181641590715b03e43919766214944966b1bcd0333d37f59c034be203979559cda2cd2 SHA512 ab4c53d65d514bb0ad8413a535eee007c1463643c805d6775524c6d1941a6cca39608f9c678b2ede394a2e986fc25ac1dd62725c1560d76e84ed038993a21fdb
+EBUILD sphinx-testing-1.0.1-r1.ebuild 554 BLAKE2B aea6aa3e3f6822762f97ad633a1ddeaf5080c24b7c9a60f6e0fb5029a98d224e19792a35e79836a88f754a5618f55cef92cd3d269ca28275aae89f7b8d9f0f76 SHA512 0f4ac215f4c00340becb71078f08c62137b420687e28ad5074eff1d93593aa88c759600dadf6ee2f715e9e2daf2b4f624870cecf387e825221fc83b64e092470
MISC metadata.xml 382 BLAKE2B bc907f0063c080ab70373e0d2e67fa2ff2f16e2c93982da1769a92bc4f67a9288e9c4f683bba89aa9cab479dd793e4ef294a726b6532fc8031f5d397e2b8c1ef SHA512 8e617b870299fbfc28e7cb6e67ea8e772e97a4886d6de808614c72b423bf557ce46005b64e37a705333edd8064f873575ae6687719a1270b1fb78f0d654e087c
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
index dfd06d45edcb..e951c6617be7 100644
--- a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -13,20 +13,9 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # NB: while tests don't stricly use nose, they rely on some side
- # effects of using it
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests nose