summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinx-testing
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest3
-rw-r--r--dev-python/sphinx-testing/metadata.xml11
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
new file mode 100644
index 000000000000..44cd1bc9a434
--- /dev/null
+++ b/dev-python/sphinx-testing/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-testing-0.7.2.tar.gz 11040 BLAKE2B 503e38eabfe8dbe28942f9165a83db2dec0f9ac52e1e55f7298848b7a6b55244e1b5623bfda7f4e1380eab16ef81cf51c6bc11e919a8b45506f17759ae0ee181 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724
+EBUILD sphinx-testing-0.7.2.ebuild 675 BLAKE2B 58664685e7d17b63cc1c68d896ec3d90fbf89ba85326cf3e148a35ab7e20501a4c974ddef203d0baddc21620956815df9e5f89bfdd30dd42f92c313a048de606 SHA512 d841d3db510092f314bad29e355ea5603b8fa263b518b9261d576494e75d27c1eb49aa95353e059d46d9b99d4f74b8ce9d07c71f7d6ceecdc4e3edb9db338464
+MISC metadata.xml 340 BLAKE2B 9a1df283aab1420d7818f4661b57f6d60cd734016c3711c633b9a6a11c401c8603503530fa5e1f50940bd28c1fed83196c1c543d16b5217b996f6afef23175a8 SHA512 f5299851dc6aa3c3ad1109123ac6c4eb5b5c7e1177fa1f068da5cef0920bbece63a8f1c424c5b95addf661e5a7d15a05a427676f6c272a54741495c77e316b78
diff --git a/dev-python/sphinx-testing/metadata.xml b/dev-python/sphinx-testing/metadata.xml
new file mode 100644
index 000000000000..605d625f69e7
--- /dev/null
+++ b/dev-python/sphinx-testing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sphinx-doc/sphinx-testing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
new file mode 100644
index 000000000000..71a84edcf47b
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*') )"
+
+python_test() {
+ nosetests || die
+}