summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sphinx-testing
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest3
-rw-r--r--dev-python/sphinx-testing/metadata.xml11
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
new file mode 100644
index 000000000000..67390d6dd3fb
--- /dev/null
+++ b/dev-python/sphinx-testing/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-testing-0.7.2.tar.gz 11040 SHA256 9d30f93007620e137b33edf19f52a7225eab853546b7e588ef09d1342e821e94 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724 WHIRLPOOL 78ea240607f62c7c3ca98fc2ba0ec197b54aba6c0782d82c4da8fd695a37baae4d0b9bcd056b790dc610979a0031cce250d19c8360ffeb07463e4335af0df026
+EBUILD sphinx-testing-0.7.2.ebuild 675 SHA256 5536c50933f81c1c5133d0924f1cc47cfff92d5d91c5a7397c86f793edc6fb2f SHA512 d841d3db510092f314bad29e355ea5603b8fa263b518b9261d576494e75d27c1eb49aa95353e059d46d9b99d4f74b8ce9d07c71f7d6ceecdc4e3edb9db338464 WHIRLPOOL 25b5f260298f7d273c7fa0a9a4cb51a5f0237e136d3f6f2a68d87abfd29fe2178eefada793403512ca55ec6b910f7a734e1c8628decebf2abff44cd45098d336
+MISC metadata.xml 340 SHA256 3e6d12eab874800d701938fc6a0696a1a61c32de6f9a0903911a7643ba62c3ff SHA512 f5299851dc6aa3c3ad1109123ac6c4eb5b5c7e1177fa1f068da5cef0920bbece63a8f1c424c5b95addf661e5a7d15a05a427676f6c272a54741495c77e316b78 WHIRLPOOL 06a4dfd300baaa96cd8d49c17a18b227262d946bcee9d2485f51f9a6598e18ef02e19fd5d8d36af1a95301cd8178a30e33f698c93297e7c58558fa4bc92e2b95
diff --git a/dev-python/sphinx-testing/metadata.xml b/dev-python/sphinx-testing/metadata.xml
new file mode 100644
index 000000000000..605d625f69e7
--- /dev/null
+++ b/dev-python/sphinx-testing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sphinx-doc/sphinx-testing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
new file mode 100644
index 000000000000..71a84edcf47b
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*') )"
+
+python_test() {
+ nosetests || die
+}