summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /dev-python/sphinx-pytest
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest2
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index 9959712bda21..b1faba471299 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-pytest-0.0.3.gh.tar.gz 5898 BLAKE2B 08fe98b3add1d76454c30a11f4d82bd04123e44fa5c28d420401014e5aef11354541781c0ba43a5d95c0c6fd35b12742ecf630005faae68125f5c6686c19ef59 SHA512 f1ee23fd5f320b5b4ac48638d509963638322374136d98516a17075e0d5b05cfa64107541c80daad424dfcd9e769a95dd5aa8d7f86d8ded214c9a3cdf901cf1f
DIST sphinx-pytest-0.0.4.gh.tar.gz 6196 BLAKE2B 24b8be165a58b15a845f076b33fb7a2525afefa7fd8bf836ac679280d271716ff02bf3adfa9b485507bc3f8a6cb91b0458a0b5bdb62bf8920c09eb20468e8949 SHA512 25bf3fafddf02aed8b2478dc2beafa251027652d03f31bbac67eb98913e359f9497a9018561aff0fdaf568ece4bcfa15705dcfa2fd3734f4db6c613b24d6a568
+DIST sphinx-pytest-0.0.5.gh.tar.gz 6228 BLAKE2B bb619ce79411a611fecf778ac095da0e7557bc419b7395efbc4dc2163699425898005fabadc083b74ac2cab8f207dcf8969f5c551c975d6354063962141c907b SHA512 e1af518cc5535ecacae612f11c7fb1200965a1999d9eb2643ba14b222fc4e93c257ef6600b37b9de4075bf3e5e703db60e7350cd5159fcf4ba21abec28bceb66
EBUILD sphinx-pytest-0.0.3.ebuild 657 BLAKE2B 0d1421e28be5e079fe5941416f04194308ae97cf78f8de661fad8ffe0a71300bc89ab5d30a667eea0b253d54878211b2b444e5cced3b32de987d1a9ac34e0cc6 SHA512 677961345eed6a5c4f687b85299f3271cffdb8df85216d192d8a822407d89bc7e792b5ddd041da9b54e62efb3caacde03194102161d85b37118cc0c87cd81a6a
EBUILD sphinx-pytest-0.0.4.ebuild 679 BLAKE2B 314648c6882a1be203ae5e5c3f538503caab21e4254e4501c7f354c836b5881595b85b1f8302d83cd705185e060c8e062c50e70f037fc2b0908b6bf4bfb248c5 SHA512 b763954ba80fa4275134a17477c2b85b6b27ac2c68facdec2fd5c51c5509544f0e24dcbb7e2da4f85999827c9ed8250d02b0a72ddb9273f4080b66975c306e3c
+EBUILD sphinx-pytest-0.0.5.ebuild 687 BLAKE2B 0d62f007cecb873ddadfa326a85f019953e16b097c5aad33974adb621b926fd8e4db70c792992ff758bf7d70da3427f6e11fff1a776d00e00506188082075787 SHA512 46acd6fc012a6ae9430d889ddbf7b8af4419fab4e0f6c68c6c341e24ae94a2ec5f4b5dc2c7f947926822f1171bb04a9aff916284d77be405062317bbbbcd9716
MISC metadata.xml 407 BLAKE2B 13becabf5e4e4ebc10ca9e3db7fb4da1909369b6a66651b2f40da2e635c851a14ffc39b7a50e4650663746abe1aaeb32b0e332c04f413f223b458b646fb066bf SHA512 8aa7f61f15f906b26c27719b2745ddaad1bd5fe70f840a7dc2b729f3c6c4f9106531c3d52860a4f98a64746582592f370b59a409acf9f646dff5ebb578fda1e1
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild
new file mode 100644
index 000000000000..729dc3cc684d
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest