summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
commit996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (patch)
tree16fac72b3f131ad5671db34f88cd6426ff602706 /dev-python/sphinx-pytest
parent0cfdfb9b75c154c98f3963d4a002425218e29efc (diff)
gentoo auto-resync : 06:06:2023 - 09:39:05
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest4
-rw-r--r--dev-python/sphinx-pytest/metadata.xml2
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.1.1.ebuild30
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index f384ffbdf532..dd86ba62d4f7 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-pytest-0.0.5.gh.tar.gz 6228 BLAKE2B bb619ce79411a611fecf778ac095da0e7557bc419b7395efbc4dc2163699425898005fabadc083b74ac2cab8f207dcf8969f5c551c975d6354063962141c907b SHA512 e1af518cc5535ecacae612f11c7fb1200965a1999d9eb2643ba14b222fc4e93c257ef6600b37b9de4075bf3e5e703db60e7350cd5159fcf4ba21abec28bceb66
+DIST sphinx-pytest-0.1.1.gh.tar.gz 6744 BLAKE2B f196a9fff7a63d1b7664f334c01f38fc44f5611be012092dad077f27bb2ddf03f2ebb7ebcbf7132a9b8c8b17166673945e9b92e88f285c4c95c4c2a696285cbc SHA512 f3210f8b2413171cc37a38fc66b8be0cd32db1a0aebb979dc9057a861711481fde6b86b7c9548166f906d9483762b864759fb4f7ba5069cda4d9fc12c1e2975c
EBUILD sphinx-pytest-0.0.5.ebuild 697 BLAKE2B d21f91547fea5e84062c31cfba53479d1080e9b7ef872feb6f3883c4b31aacec8e466ff544996b0a058a3d51cb7db4a545b21a13d912411a0edac7e8224001f1 SHA512 c99e1bb45572f9035d1a4d89467994e274e7f1f25a29f889ea6c5af804426ad1394e21469f4f25f8eae374b1efaeeda93eddda6ab701dcc5385ed8f94bfa48fd
-MISC metadata.xml 407 BLAKE2B 13becabf5e4e4ebc10ca9e3db7fb4da1909369b6a66651b2f40da2e635c851a14ffc39b7a50e4650663746abe1aaeb32b0e332c04f413f223b458b646fb066bf SHA512 8aa7f61f15f906b26c27719b2745ddaad1bd5fe70f840a7dc2b729f3c6c4f9106531c3d52860a4f98a64746582592f370b59a409acf9f646dff5ebb578fda1e1
+EBUILD sphinx-pytest-0.1.1.ebuild 718 BLAKE2B 01b1ee30d50cf8c5152340fadd593bf7f6f3e42db2b5ebb3471968e70db69ddb05e090767116c8060b1356d1a5d2dc9c7bb31f6ec0448071e5bbfee090f6c4a0 SHA512 472dd1f4cf2e4b54a5d72117c567a17cdb9dac30440c5a0a11e0383afd52154f9ff30686081f7688380d970ca3080ea4aa8fb011cabaf1d75131af00ee4fda97
+MISC metadata.xml 413 BLAKE2B 688b027b22ac7d6ee04627c8ad7134d5993892e4b0f63739d432abb76291c32ac7cf8ad5ee8c53c22a6f6a0f29082c9781fdba0290f2015a603b6d8be85df285 SHA512 3b9967e4e96a723af552df502c0f57633ecc1669348f11f005ce451d212ec9e1ad3e2d3d75ddf5da4445c7196ad337a1ffb65d0aa1393ca932d4adb04329e118
diff --git a/dev-python/sphinx-pytest/metadata.xml b/dev-python/sphinx-pytest/metadata.xml
index d0dabef2414d..f7907b42a5f7 100644
--- a/dev-python/sphinx-pytest/metadata.xml
+++ b/dev-python/sphinx-pytest/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">chrisjsewell/sphinx-pytest</remote-id>
+ <remote-id type="github">sphinx-extensions2/sphinx-pytest</remote-id>
<remote-id type="pypi">sphinx_pytest</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.1.1.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.1.1.ebuild
new file mode 100644
index 000000000000..5cf11f8e357d
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/sphinx-extensions2/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/sphinx-extensions2/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest