summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/sphinx-pytest
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest5
-rw-r--r--dev-python/sphinx-pytest/metadata.xml13
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild30
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild30
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
new file mode 100644
index 000000000000..54bda157db61
--- /dev/null
+++ b/dev-python/sphinx-pytest/Manifest
@@ -0,0 +1,5 @@
+DIST sphinx-pytest-0.0.3.gh.tar.gz 5898 BLAKE2B 08fe98b3add1d76454c30a11f4d82bd04123e44fa5c28d420401014e5aef11354541781c0ba43a5d95c0c6fd35b12742ecf630005faae68125f5c6686c19ef59 SHA512 f1ee23fd5f320b5b4ac48638d509963638322374136d98516a17075e0d5b05cfa64107541c80daad424dfcd9e769a95dd5aa8d7f86d8ded214c9a3cdf901cf1f
+DIST sphinx-pytest-0.0.4.gh.tar.gz 6196 BLAKE2B 24b8be165a58b15a845f076b33fb7a2525afefa7fd8bf836ac679280d271716ff02bf3adfa9b485507bc3f8a6cb91b0458a0b5bdb62bf8920c09eb20468e8949 SHA512 25bf3fafddf02aed8b2478dc2beafa251027652d03f31bbac67eb98913e359f9497a9018561aff0fdaf568ece4bcfa15705dcfa2fd3734f4db6c613b24d6a568
+EBUILD sphinx-pytest-0.0.3.ebuild 657 BLAKE2B 0d1421e28be5e079fe5941416f04194308ae97cf78f8de661fad8ffe0a71300bc89ab5d30a667eea0b253d54878211b2b444e5cced3b32de987d1a9ac34e0cc6 SHA512 677961345eed6a5c4f687b85299f3271cffdb8df85216d192d8a822407d89bc7e792b5ddd041da9b54e62efb3caacde03194102161d85b37118cc0c87cd81a6a
+EBUILD sphinx-pytest-0.0.4.ebuild 663 BLAKE2B 14a4b1a8c3ae17ad68e607078b8d912259ee54b3433395adba816beede3146d28b21b8959764c3c472f3c7481c86b2dbdff526b03944961d45afe003a070efe4 SHA512 1d4f3a1fe717668e9b99d90d36898c1c2f769db871bc60069ff3ea23cf2e7422feedf13b809c0f5d36cdd0e83b6a3bd1e08768de6bad8509cc1ebb6b20b519c6
+MISC metadata.xml 407 BLAKE2B 13becabf5e4e4ebc10ca9e3db7fb4da1909369b6a66651b2f40da2e635c851a14ffc39b7a50e4650663746abe1aaeb32b0e332c04f413f223b458b646fb066bf SHA512 8aa7f61f15f906b26c27719b2745ddaad1bd5fe70f840a7dc2b729f3c6c4f9106531c3d52860a4f98a64746582592f370b59a409acf9f646dff5ebb578fda1e1
diff --git a/dev-python/sphinx-pytest/metadata.xml b/dev-python/sphinx-pytest/metadata.xml
new file mode 100644
index 000000000000..d0dabef2414d
--- /dev/null
+++ b/dev-python/sphinx-pytest/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">chrisjsewell/sphinx-pytest</remote-id>
+ <remote-id type="pypi">sphinx_pytest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild
new file mode 100644
index 000000000000..5dda95b0b5eb
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild
new file mode 100644
index 000000000000..1d77e086683c
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest