summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
commit03633f33c2184a87f7a4cebae72542343cf0490c (patch)
tree51a044dec7586be070d68ebb95d563883b02c726 /dev-python/sphinx-pytest
parentc0e834f207174ee62c093753cea0176c947a9ba1 (diff)
gentoo auto-resync : 21:09:2023 - 11:14:12
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest2
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index d807c883dab8..82c6a1482cf5 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-pytest-0.1.1.gh.tar.gz 6744 BLAKE2B f196a9fff7a63d1b7664f334c01f38fc44f5611be012092dad077f27bb2ddf03f2ebb7ebcbf7132a9b8c8b17166673945e9b92e88f285c4c95c4c2a696285cbc SHA512 f3210f8b2413171cc37a38fc66b8be0cd32db1a0aebb979dc9057a861711481fde6b86b7c9548166f906d9483762b864759fb4f7ba5069cda4d9fc12c1e2975c
+DIST sphinx-pytest-0.2.0.gh.tar.gz 6935 BLAKE2B a18755669865512ee5ecec46abebf654705efb64165306126144af9df056a829efc5c818abad2477e86edb3da2cb1bf4aadc4e8807cf3c289e29fffa249bbfbf SHA512 dfcbe36c74bf01ff45895893faa11a643b667d277e5f5011978c5cd1404f79d614c6603cf8756ef3e5fec278ea01c6e289cb825725e4e218f75a7bcb12e11bbb
EBUILD sphinx-pytest-0.1.1.ebuild 710 BLAKE2B 0cc0bd2488dc987400b1574c911bd606cb67e0c0c2d0aa74900cc6851c2b60d0057e3109ec9852000e98f5f93d7f2b077b6a1eee1f9bf56f08143861e540c6b8 SHA512 84d87f22fa83181878ab463192239c79bfcba13f140ba499a61fb77bc9916a145393ca68cba6b94770b141f4f01e4b4a60889c7f49e230bf3022e209ab37de5b
+EBUILD sphinx-pytest-0.2.0.ebuild 718 BLAKE2B 01b1ee30d50cf8c5152340fadd593bf7f6f3e42db2b5ebb3471968e70db69ddb05e090767116c8060b1356d1a5d2dc9c7bb31f6ec0448071e5bbfee090f6c4a0 SHA512 472dd1f4cf2e4b54a5d72117c567a17cdb9dac30440c5a0a11e0383afd52154f9ff30686081f7688380d970ca3080ea4aa8fb011cabaf1d75131af00ee4fda97
MISC metadata.xml 413 BLAKE2B 688b027b22ac7d6ee04627c8ad7134d5993892e4b0f63739d432abb76291c32ac7cf8ad5ee8c53c22a6f6a0f29082c9781fdba0290f2015a603b6d8be85df285 SHA512 3b9967e4e96a723af552df502c0f57633ecc1669348f11f005ce451d212ec9e1ad3e2d3d75ddf5da4445c7196ad337a1ffb65d0aa1393ca932d4adb04329e118
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild
new file mode 100644
index 000000000000..5cf11f8e357d
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/sphinx-extensions2/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/sphinx-extensions2/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest