summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-prompt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-08 12:38:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-08 12:38:45 +0100
commit14866757225815b9374acfc8453518951e0f910d (patch)
tree3fc69d84de25c5d40515dc05fdf5c5934ed69955 /dev-python/sphinx-prompt
parentb8c7370a682e4e29cda623222d17a790c01c3642 (diff)
gentoo auto-resync : 08:08:2024 - 12:38:45
Diffstat (limited to 'dev-python/sphinx-prompt')
-rw-r--r--dev-python/sphinx-prompt/Manifest2
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.9.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/Manifest b/dev-python/sphinx-prompt/Manifest
index 3575aace47be..a27f420401d3 100644
--- a/dev-python/sphinx-prompt/Manifest
+++ b/dev-python/sphinx-prompt/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-prompt-1.8.0.gh.tar.gz 38424 BLAKE2B c469e2acfdad076afd472c30380a59aae4d719edce653794fd4d09a2c8008b7f67642ce2a740fb1408987243ba5d520e28b3dc4d7ec34899de6fcf57f2171456 SHA512 1acaa18066537adaab71eb900f0b0fb8041f8f25a9079e171b98b98106d5b7d1885e23bae2c1fd278bbf22c66d17238fbf386cb61fc5725475862aaf86d5701e
+DIST sphinx-prompt-1.9.0.gh.tar.gz 39458 BLAKE2B 16b646bd0e288da3d2f401650c3131c7c6b9fb27023617717821927c7bd8b8d031f14d82b7dd02c6603f3ece084e766a28022cc418867646d770886cdce538ce SHA512 f9ee34b86ead0eda791ba7d648ae54785c09ca276279197c4632963892a03080e547d1930743d81ddb3b327c912c70a58dea968b1da763c4875ec84014b207f8
EBUILD sphinx-prompt-1.8.0.ebuild 1079 BLAKE2B 4e643538c1a970d07a7d578498f924d44a073795e8d171aa1d77dfd701dfedd418fdb54e96efe94dc95a0b38066415d695ed3b7cea149fb90ed2af2f47b7f5d9 SHA512 70aa685813e870bee106a410b5988260c661f0487764abd4869f81ab5e94c821bdcf465c6144ffa0fe33cf29858eb38de6fad2bc8f2e6a63c1857fa67f552677
+EBUILD sphinx-prompt-1.9.0.ebuild 1087 BLAKE2B 1c7bab228ab2b1c2028dccae91f0ff215e9aa0b04073048b6239f36218c47e6590c73154987b4807f5dc0f42c1d09cf6a8d43e7041d62964ea1c276e395f469d SHA512 aab0cdc9d4f8c5fb61b2a06c99291c4b96cec0944d9db7fcdccea7eae66ee301ef3e1f63abcc1df3f1f9821dcab2e09146fc0807c5f9e4892c4d5e2101ef75b8
MISC metadata.xml 416 BLAKE2B 5c9110bc6a6c0c7acab6e9f10d8d84601a66c7741ba15612eb032272db9517f314eec8f86677e43fd7dfb1b032388b1db3b60c64e0cd9a6943498c4715ebf1e0 SHA512 5d23f08978f7ca0dae7062a4a872f1be37969144c128c4a1f2006798465b5dbf95090e14859eb6c7e1e75649170e40fe156e6b9cd5b1263464e88edffc760a15
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.9.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.9.0.ebuild
new file mode 100644
index 000000000000..6daa0821df96
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="
+ https://github.com/sbrunner/sphinx-prompt/
+ https://pypi.org/project/sphinx-prompt/
+"
+SRC_URI="
+ https://github.com/sbrunner/sphinx-prompt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # version number relies on git repo, sigh
+ # also all dependencies are pinned to exact versions, sigh
+ # also huge hack to install package as "sphinx-prompt", sigh
+ sed -i \
+ -e "/^version =/s:[0-9.]\+:${PV}:" \
+ -e '/^\[tool\.poetry\.dependencies\]$/,$s:"[0-9.]\+:"*:' \
+ -e '/include.*sphinx-prompt/d' \
+ pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}