summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
commitd12ee3457fd1a8bf18ede06882314fc1df30bd4b (patch)
tree33d42f682bfdfdf5fc26dd6bdd779853b8441ca0 /dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
parent53aea9d709c9286028405b25584181507f47442f (diff)
gentoo auto-resync : 31:07:2023 - 16:45:16
Diffstat (limited to 'dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild')
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
new file mode 100644
index 000000000000..b8e7c5e14a20
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="
+ https://github.com/sbrunner/sphinx-prompt/
+ https://pypi.org/project/sphinx-prompt/
+"
+SRC_URI="
+ https://github.com/sbrunner/sphinx-prompt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream repeatedly fails to update version number
+ # also pins all dependencies to exact versions, sigh
+ sed -i \
+ -e "/^version =/s:[0-9.]\+:${PV}:" \
+ -e '/^\[tool\.poetry\.dependencies\]$/,$s:"[0-9.]\+:"*:' \
+ pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}