summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-panels
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 01:54:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 01:54:17 +0000
commit89e7f1cd6dd17f245898939477ef38d45dd112b9 (patch)
tree6b02444048d0d92ccbf6f3e8c538c152f57086c2 /dev-python/sphinx-panels
parent1252b7a51c2cc6bd3a81830544cacce0aefc0bf1 (diff)
gentoo auto-resync : 19:12:2023 - 01:54:16
Diffstat (limited to 'dev-python/sphinx-panels')
-rw-r--r--dev-python/sphinx-panels/Manifest3
-rw-r--r--dev-python/sphinx-panels/files/sphinx-panels-0.6.0-sphinx-7.patch65
-rw-r--r--dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild29
3 files changed, 92 insertions, 5 deletions
diff --git a/dev-python/sphinx-panels/Manifest b/dev-python/sphinx-panels/Manifest
index a5b295c36bd4..6a7fadad177b 100644
--- a/dev-python/sphinx-panels/Manifest
+++ b/dev-python/sphinx-panels/Manifest
@@ -1,3 +1,4 @@
+AUX sphinx-panels-0.6.0-sphinx-7.patch 2678 BLAKE2B 70f0843288d3ec354bf505864265f84a28e3463a56194e7efebcbbe1163cb2a9eab0d62914d48f963a1c66742dc5871439f03e93c28e2ca5454bf4922234dc5b SHA512 c84a96f3a689afc3f508643c1626c6ca129cb797c1c56f6d63c9a082f3b82511f3032f2d4fbd998185cdc96ea4f984a8d5f19c4b046be90058c70246a612916e
DIST sphinx-panels-0.6.0.gh.tar.gz 400548 BLAKE2B 685b241ffe839face392950ccaa5c00d5613ee4076a4f8d62fdff32158f2d02c444375b7f656a89d4712f8bf895b937ff9fe650cab98670f03b0c4d75e545f97 SHA512 74064538ff8cd1c7c44b5daeda272217618ed33394694883046972b4262d503e1426e7573d8b49040d4b426651377b89fd4ad2a085f1e62827e7ef51e6912e5f
-EBUILD sphinx-panels-0.6.0-r1.ebuild 722 BLAKE2B 96d4fb17c625a77b9bdf59594c9ef9a0ad195754ca85144f379fa872bfcc90f9a25a7bdcfdb7f1072e5382ff07027cc659d838498eb0a64bdbcc7b7d1c1b9398 SHA512 d614c471234a8f45a35a73679d636db65e0e1db58db292378d2da1d5d78c1f866a711b67b7205b1ba4172fb8ad545ff5325a45905e5f90dbb0975af02d2d8b84
+EBUILD sphinx-panels-0.6.0-r1.ebuild 988 BLAKE2B d3255244c89423a08d46070bc3caab1ea05e16de383ab007cb78fdfb98d1f870728c5df294aabe5b7a3ceb0caf8d817e60161ca6876a78046dec91a03e6c057c SHA512 a6195686b05bdc350123ff335cc4af2523aa03e9819814f2dc73be29745ce5c7e574845378eb4f136ac95f61483f112f215dd4a1dce71f28e80e7f57198d2ca6
MISC metadata.xml 529 BLAKE2B 2f0bec5e5370efe7b98dccbe428e55649617ab2456c93d42e8340ae1dd412e5f2cfbd0036c3e864366a6865f7baf631975ba88054cdb558f21bc98b4d69bad54 SHA512 37fb3f14ef72b9deee418215483a033e595012db61d96663fb36bba70357713cd300a9b6a157c9585f996eab5c0946bf29474de19704ebe74c9a40d3c8ac7911
diff --git a/dev-python/sphinx-panels/files/sphinx-panels-0.6.0-sphinx-7.patch b/dev-python/sphinx-panels/files/sphinx-panels-0.6.0-sphinx-7.patch
new file mode 100644
index 000000000000..8bd3ebb0706b
--- /dev/null
+++ b/dev-python/sphinx-panels/files/sphinx-panels-0.6.0-sphinx-7.patch
@@ -0,0 +1,65 @@
+https://salsa.debian.org/python-team/packages/sphinx-panels/-/blob/debian/master/debian/patches/Make-the-tests-pass-with-Sphinx-7.x.patch
+
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Fri, 3 Nov 2023 23:25:11 +0300
+Subject: Make the tests pass with Sphinx 7.x
+
+---
+ tests/test_sphinx.py | 8 +++++++-
+ tests/test_sphinx/test_sources_dropdown_basic_.xml | 2 +-
+ tests/test_sphinx/test_sources_tabbed_basic_.xml | 2 +-
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/tests/test_sphinx.py b/tests/test_sphinx.py
+index 9efc2c2..35affa1 100644
+--- a/tests/test_sphinx.py
++++ b/tests/test_sphinx.py
+@@ -2,6 +2,7 @@ from pathlib import Path
+ import shutil
+
+ import pytest
++import sphinx
+ from sphinx.testing.path import path
+
+ from sphinx_panels.tabs import TabbedHtmlTransform
+@@ -15,7 +16,10 @@ def sphinx_app_factory(make_app, tmp_path: Path, monkeypatch):
+ shutil.copytree(
+ (Path(__file__).parent / "sources" / src_folder), tmp_path / src_folder
+ )
+- app = make_app(srcdir=path(str((tmp_path / src_folder).absolute())), **kwargs)
++ srcdir = (tmp_path / src_folder).absolute()
++ if sphinx.version_info < (7, 2):
++ srcdir = path(str(srcdir))
++ app = make_app(srcdir=srcdir, **kwargs)
+ return app
+
+ yield _func
+@@ -28,6 +32,8 @@ def test_sources(sphinx_app_factory, file_regression, folder):
+ assert app._warning.getvalue() == ""
+ doctree = app.env.get_and_resolve_doctree("index", app.builder)
+ doctree["source"] = "source"
++ if sphinx.version_info < (7, 1):
++ doctree["translation_progress"] = "{'total': 0, 'translated': 0}"
+ file_regression.check(
+ doctree.pformat(),
+ encoding="utf8",
+diff --git a/tests/test_sphinx/test_sources_dropdown_basic_.xml b/tests/test_sphinx/test_sources_dropdown_basic_.xml
+index b984330..4c42825 100644
+--- a/tests/test_sphinx/test_sources_dropdown_basic_.xml
++++ b/tests/test_sphinx/test_sources_dropdown_basic_.xml
+@@ -1,4 +1,4 @@
+-<document source="source">
++<document source="source" translation_progress="{'total': 0, 'translated': 0}">
+ <section ids="title" names="title">
+ <title>
+ Title
+diff --git a/tests/test_sphinx/test_sources_tabbed_basic_.xml b/tests/test_sphinx/test_sources_tabbed_basic_.xml
+index b3f2d1a..f55e06e 100644
+--- a/tests/test_sphinx/test_sources_tabbed_basic_.xml
++++ b/tests/test_sphinx/test_sources_tabbed_basic_.xml
+@@ -1,4 +1,4 @@
+-<document source="source">
++<document source="source" translation_progress="{'total': 0, 'translated': 0}">
+ <section ids="title" names="title">
+ <title>
+ Title
diff --git a/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
index c076a2d8c2e1..ad0f2761cb85 100644
--- a/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
+++ b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="A sphinx extension for creating panels in a grid layout"
-HOMEPAGE="https://github.com/executablebooks/sphinx-panels"
-SRC_URI="https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-panels/
+ https://pypi.org/project/sphinx-panels/
+"
+SRC_URI="
+ https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -19,8 +26,22 @@ RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
-BDEPEND="test? ( dev-python/pytest-regressions[${PYTHON_USEDEP}] )"
+PATCHES=(
+ # https://github.com/executablebooks/sphinx-panels/pull/84
+ "${FILESDIR}/${P}-sphinx-7.patch"
+)
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+ distutils-r1_src_prepare
+}