summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/sphinx-notfound-page
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest2
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 9d18a478da99..218708cb48d2 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-notfound-page-1.0.2.gh.tar.gz 543984 BLAKE2B a6a7a1f157c9500618c296152f44a441db9bf4198e196e5be5c71444e05f2623457d0807103dcc55d08c869afb0d35b719dc73f7f43e57f08a025aa08a4f42b1 SHA512 faa6c2cf59dcb3ab90e00176f1f9480ad8f5ff07e76dfd49a17985e638ea05329faaffa15f64d5c7cedc37028d0beeee9de10927429eb85d5b0bb1397d6bd14e
+DIST sphinx-notfound-page-1.0.4.gh.tar.gz 544117 BLAKE2B f8155167183fa3d6487cfd9f93eff8a99dd3253ed7f44632ca822b9da3d0b409a6897edd4f972fc9535b4759c2ef976c5f66daf85249ba9de4c83ae96ff65d7a SHA512 d6643e29768b31834c73302f8995cd92c052b2a51a4ecffc997f4ea4d15cf830c17a2f538fec637b1a3a7e187fa787252652b5ab8ce0ab92f44996a63669b504
EBUILD sphinx-notfound-page-1.0.2.ebuild 848 BLAKE2B e181a18fa38b164602335439a316b7042ec9359288e83dd1f66316d96b0ddfbba898eb9fb5c4e80745dcf129a12039a21a15e7ca56da1a0f4a2fd9c434653922 SHA512 d3d1afe95e8b4d71ed488ca4eb61091b5a2cebf8b7223b3aac00ae10757c6f01d0d6508f668f30214cd5f46640e6f6895706f1f9d2a99c8059dc578160581730
+EBUILD sphinx-notfound-page-1.0.4.ebuild 856 BLAKE2B 04c39ae7acd98cb1984e57bfe4351fb812621c0f13922230deab8c4f8e52fed937f733267ef701ecedf3cd1613a6ee7bd920906279f9b737b06da048ec9ba6d9 SHA512 d906ba5d79bd565900f05fcc130f03004aea873d5ffc495aedd753ff100f9cb6e1609bdf996315b6047ef1254db24e285cefc0b27d596ac88df7b73bc1cb442b
MISC metadata.xml 651 BLAKE2B 7b4c1c58782b6a1e6118744d4933d8bfc1391fef578350f9622dddfb911a4319be8fc2cd2a297d5ac84bb97249d520a1cb740ed00d6314cb3cbf1dce5c119dfd SHA512 4b531fde722c6f0f0709405669efe61cfe2fd14e52f627ee67001b81d5268444b226630f55c6dc6a149ea86699379289368826429754abbad6cdaf36f1f4a673
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild
new file mode 100644
index 000000000000..2160322293ab
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)