summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-lv2-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-python/sphinx-lv2-theme
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-python/sphinx-lv2-theme')
-rw-r--r--dev-python/sphinx-lv2-theme/Manifest5
-rw-r--r--dev-python/sphinx-lv2-theme/metadata.xml13
-rw-r--r--dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.0.ebuild22
-rw-r--r--dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.2.ebuild19
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/sphinx-lv2-theme/Manifest b/dev-python/sphinx-lv2-theme/Manifest
new file mode 100644
index 000000000000..773d30093066
--- /dev/null
+++ b/dev-python/sphinx-lv2-theme/Manifest
@@ -0,0 +1,5 @@
+DIST sphinx_lv2_theme-1.4.2.tar.gz 14331 BLAKE2B 3d0e40af9a48c0595b1b99b87ca6fc35a557d0f7543609ab71deb277563c9c460ac6310179f0384510143fa4056bce1c1338e481f812393ffa82e063c14bc067 SHA512 51c9cca9cd28878496706a4716ec722b695257392ab09adfbfe70e3dadeb72c7620cdbb56562411e8b99d3af942cec63a346781512ead188c6b2d6eae3623336
+DIST sphinx_lv2_theme-v1.4.0.tar.bz2 10368 BLAKE2B c4ef7bb51965ebecb193d13b6d3866db6234bec8387c9e532550cafb14bf404711715f60831912770998e4cd9feb21a7d3ea1d8e987e276ec644ce51f63e6be6 SHA512 fba7af83bbc7e47a3a87e7b819cd83009b4b2e04e6280efe56b0f7bc348f784a85f004b7124a5c3704329be95a0432ca690f9675e6b9330ecf493994258ddc8c
+EBUILD sphinx-lv2-theme-1.4.0.ebuild 617 BLAKE2B 31ad39b3714d1f7abbde77e95f94878fa5efb727cb1faad22df202806081ceb65ba962015b0c213ce9a628c7f48c05c7165fe7e9860f98c7714cf62d1838fa34 SHA512 bcddfd7ad0ade1e1a1ea82586010cd4ef3fe3104e84edd922e1031b16ccef0b61a8105f93a7c47449f22b75827356aa60eefa40e057f7c6cc7004f2611270f47
+EBUILD sphinx-lv2-theme-1.4.2.ebuild 502 BLAKE2B dd842330baa79230c76f0cc2591f60d53987f33bb2f2e2d6984e04ae3c9774f99351ede08ccaf5c4a6de1f724cf5c74e7df9b747a02ff01ad29f7774c068ec74 SHA512 40772ba7b23aeed9739dc4a9fac8972305eed32d7e1955c138b9c1dc305a21029d05b95eac6b84e5281801a8df4ab47aeb63686959470ffb0e633a76adbbaa8b
+MISC metadata.xml 429 BLAKE2B b4e7eb03faabacbb5a7b41f1b0b04ae1580f7a00959b0d0e575577cf0b93f1551773c492826c7635c6cfd18af0e608a23e7fceedb76ef99920c1f09fcd51ee17 SHA512 ac2b159c1a66cf08d5d4990150b0e930b40bfe8ab7f016e3b7d0d479110c0b8c402f33b46175dc31b56e6136a26fc84223e82fe5bdd87cf3de1a6b175254c62a
diff --git a/dev-python/sphinx-lv2-theme/metadata.xml b/dev-python/sphinx-lv2-theme/metadata.xml
new file mode 100644
index 000000000000..322e4eff0904
--- /dev/null
+++ b/dev-python/sphinx-lv2-theme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>ProAudio Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="gitlab">lv2/sphinx_lv2_theme</remote-id>
+ <remote-id type="pypi">sphinx-lv2-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.0.ebuild b/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.0.ebuild
new file mode 100644
index 000000000000..786fa8d85e64
--- /dev/null
+++ b/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${PN//-/_}-v${PV}
+DESCRIPTION="Minimal pure-CSS Sphinx theme using the LV2 plugin documentation style"
+HOMEPAGE="
+ https://gitlab.com/lv2/sphinx_lv2_theme/
+ https://pypi.org/project/sphinx-lv2-theme/
+"
+SRC_URI="https://gitlab.com/lv2/sphinx_lv2_theme/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
diff --git a/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.2.ebuild b/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.2.ebuild
new file mode 100644
index 000000000000..5ddaa0365e87
--- /dev/null
+++ b/dev-python/sphinx-lv2-theme/sphinx-lv2-theme-1.4.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Minimal pure-CSS Sphinx theme using the LV2 plugin documentation style"
+HOMEPAGE="
+ https://gitlab.com/lv2/sphinx_lv2_theme/
+ https://pypi.org/project/sphinx-lv2-theme/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"