summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-issues
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-python/sphinx-issues
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-python/sphinx-issues')
-rw-r--r--dev-python/sphinx-issues/Manifest3
-rw-r--r--dev-python/sphinx-issues/metadata.xml12
-rw-r--r--dev-python/sphinx-issues/sphinx-issues-1.2.0.ebuild20
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx-issues/Manifest b/dev-python/sphinx-issues/Manifest
new file mode 100644
index 000000000000..df064d595d23
--- /dev/null
+++ b/dev-python/sphinx-issues/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-issues-1.2.0.tar.gz 8051 BLAKE2B 2f17738719f92be1e4ef2d7e2e0b7c123f6f924e4bfea82e2151ed96b9fdbe2cf676bddc5c009a947e1172a84131a1a58a3bf0758f045a636bd4cb7ec496fa68 SHA512 8814e910b111f0b241bc40a93de8b6ff1acd24437f1b014b24691b3bbaaadaadaded82175067d8992bb482f4bfcdec570cdd26b4c6858d7af60d5dd3f0638b64
+EBUILD sphinx-issues-1.2.0.ebuild 711 BLAKE2B cb37777e2d5caf682db8bd0d61c01552048b75bd85f7fe045c70bf0f6cbbea1ff0d0da3a89f96fc3fcb5007c7fc5b0c23f847abffa4c27807bc53d28f333acfd SHA512 f253db19cdc88670fa2e7ac168befa58b26a9d452aa7c0a08d81f3614814cb3504a53e6048b804fea62f5dfb1439fe8e17a715ff826d3d4fcb11efaf98d4b04c
+MISC metadata.xml 388 BLAKE2B 192707563103236482cf5de03630e3b39f6827f446ba6e058e29c384d6e989e3b96b3f54b5e353426022328f81596ba3c70c61f3f84f69b3c20f34163836b74c SHA512 3b29ce4fbde49727c8dfd8f7f28f3baea1ca5feb60a1ab21b8ac0b597326e702941cb0190903aa930d55358c092bb5ba6b31d27f9acf8940380557c562ea659c
diff --git a/dev-python/sphinx-issues/metadata.xml b/dev-python/sphinx-issues/metadata.xml
new file mode 100644
index 000000000000..17cccf68901e
--- /dev/null
+++ b/dev-python/sphinx-issues/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinx-issues</remote-id>
+ <remote-id type="github">sloria/sphinx-issues</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-issues/sphinx-issues-1.2.0.ebuild b/dev-python/sphinx-issues/sphinx-issues-1.2.0.ebuild
new file mode 100644
index 000000000000..16ec95d7500b
--- /dev/null
+++ b/dev-python/sphinx-issues/sphinx-issues-1.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A Sphinx extension for linking to your project's issue tracker "
+HOMEPAGE="https://github.com/sloria/sphinx-issues"
+SRC_URI="https://github.com/sloria/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest