summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/sphinx-gallery
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 55df7bd18dd0..bf4ccb2be6e0 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-gallery-0.1.12.tar.gz 68976 BLAKE2B c9f8f12f775df8cac0f0ad7d70b0dd099dacb3b005584d1bbc878437443144d7e2613ceecd25cd4b0c8941818c5596f6435c1fa223b1e5c5d5196827a69163fb SHA512 57e8fc3746c2f5c941ddc3e00c749a6bfa63fb5741b3e5551df02f798858c417acee05a6b35512506aa0c4866b14a093cb4269284501672c3bbbf2edfc1edc1d
+DIST sphinx-gallery-0.3.1.tar.gz 88807 BLAKE2B 79218a1f438e2b8607c52b14f098c0136cb4d5ce15a12d82bdb3caf0c7c1090e7c4f210437fc660d8d4d19bf87bbaa2ec3c208d2dc8a77ad9deea5b5cefa3c05 SHA512 c51eaaef63a7496e223a4541d0560f694420b6ac4b2cde3779c405f0ab92d34aef7a37e4c41da9e59bd8a050c8d3eed330df3799e76a60ae35cdbc6f7c9cb8c1
EBUILD sphinx-gallery-0.1.12.ebuild 733 BLAKE2B 0f8cd47e017894f01752ee41baa318f634f88f08cc124af08fb1cc8a7c685048a9de1c329a59b3236f521d70a35c4c0cc53f1396d784f69a7be7a5d32e73e175 SHA512 cbd0232a27ebda6c892416584263c15fa46b3648854654bd9ad3aec2d62925865fcf4e606ca462781ab5a728962b6d3070af6303084a09052b435bb08d061e20
+EBUILD sphinx-gallery-0.3.1.ebuild 680 BLAKE2B 63f80723329bb24afc9c59b8ba39db351737d6efa0139cb2de714fe7ff60e44450cee82fb767263e53115663474b99065786b8b324ddc4b383a3ce39d153bcd4 SHA512 78c7bd2d208ceef98d6eafe8ba138c462ea53dcfd6c4c3280651c385d810fab30f052d35ffce6f0e9a694a7523296a4d2e18c9512f7880c5ea288d6b2b0d93de
MISC metadata.xml 398 BLAKE2B 9ba3eb9dc8d9d9e16cb83963ab758bdcd11c6f7c8ff5ee6a9244b8c0e9c9db2162a22b855bdcd43148c0d23ef8c31c075e36bd4afdffa1a2eb5f30d08ce00747 SHA512 3b9762099b163b539d7de52602291433608ef33a9e60d3713e07bcf0b2b8345a52a0b162f6be52c9a88cfd419e5bc4e59307d07213f1d5aa3c4ca892d91f8b9b
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild
new file mode 100644
index 000000000000..4f1ae7b02a29
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests need extra files not distributed