summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
commitd628c1f8493d09e3deb5d19971cd21691d8758e4 (patch)
tree7afecb9f9148ecf631ac2093143278e041cc5acd /dev-python/sphinx-gallery
parent4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (diff)
gentoo auto-resync : 01:03:2025 - 19:28:40
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest4
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild51
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.19.0.ebuild2
3 files changed, 2 insertions, 55 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 22edc5c554e6..3b7c231613b1 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,5 +1,3 @@
-DIST sphinx_gallery-0.18.0.tar.gz 466371 BLAKE2B 5d01bf19fa24d32ea667e7846dae03a85b470f430204a20d65efb988d54a8a6462e8cb6bed03de6f240c4945fbb1aa5e839d84feddd8093ab303d846773e4097 SHA512 59712e6a50d0a01e091b51e8532798ba4068a3a65472c25ea5a913dea599ac1afa54c44a057d332e6204930fa958d5b88dafe796af913566f504f0d9cf91e72a
DIST sphinx_gallery-0.19.0.tar.gz 471479 BLAKE2B 335d976be4786c522693d5a5c08bbcf29aea6c571187fef77d582b827c4958e34bf1a86fec7012fc6af921600b925f46c25924522c0c5c96519331cb42a30c16 SHA512 90ed1aafa718937ee9bd5c8f52937c5a65058ca5a2138606f48f41637dae8a1d3c22cfcbed2eef3aaf3180ee137d943cfbde72ba2625c23f6d7d8e911f3f374f
-EBUILD sphinx-gallery-0.18.0.ebuild 1462 BLAKE2B cda85cc45591462503dc992c4aac30eedbe9bf3ba1040c4afe9db8d6dafaf4a8aa1ffd71063f29c0ad0aa582c7c97a4332caac6f6e7b3d1a2b62978d15f61510 SHA512 3db83cb5feb60425e43a408817d2b928273f89ee1af70e252a8075d44fd03c894aa670cb1175ca064eae74538a04d95a7c6785ecabde5ef7a7689898aa1560bf
-EBUILD sphinx-gallery-0.19.0.ebuild 1466 BLAKE2B e32645708ea51e7239ad7b372bee469359c4ec2df381bda9345b197a9767d9531b86e2f624b7e5ef06dde88973b07a6f807a409971c6bc229ac1f019af48252d SHA512 c7708b36bb1794996d4c0db8c2f608103767115ade25d76446881ad7dee713bdd99b882dd711c462c91e389a657f1427a0d1b1ab92c65eb6eb22fc31c2c428de
+EBUILD sphinx-gallery-0.19.0.ebuild 1462 BLAKE2B cda85cc45591462503dc992c4aac30eedbe9bf3ba1040c4afe9db8d6dafaf4a8aa1ffd71063f29c0ad0aa582c7c97a4332caac6f6e7b3d1a2b62978d15f61510 SHA512 3db83cb5feb60425e43a408817d2b928273f89ee1af70e252a8075d44fd03c894aa670cb1175ca064eae74538a04d95a7c6785ecabde5ef7a7689898aa1560bf
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild
deleted file mode 100644
index 491d9054b760..000000000000
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{11..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
-HOMEPAGE="
- https://github.com/sphinx-gallery/sphinx-gallery/
- https://sphinx-gallery.github.io/
- https://pypi.org/project/sphinx-gallery/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- >=dev-python/sphinx-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/joblib[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
- sphinx_gallery/tests/test_full.py::test_run_sphinx
- sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
- # require jupyterlite_sphinx
- sphinx_gallery/tests/test_full.py
- sphinx_gallery/tests/test_full_noexec.py
- sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
- sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
- sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
- )
-
- epytest -o addopts=
-}
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.19.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.19.0.ebuild
index 61705d97e6c8..491d9054b760 100644
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.19.0.ebuild
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.19.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]