summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
commit5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (patch)
treed3996b456278fbe1e1528053ddd115c4bac05401 /dev-python/sphinx-gallery
parent413421048cc2b0df9a218f0ab3cb151846809eb5 (diff)
gentoo auto-resync : 28:04:2024 - 23:59:44
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.16.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 499e7e654d5c..14355c9c0f6c 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-gallery-0.15.0.tar.gz 422363 BLAKE2B cbca8ec252e03e9cacc0df27da43ebc9bbed8531d5df65bf9cb7f54f7ae8b127582f353cb245bcc459d6fa86240207346a05d777504163d49be0fabb029a172b SHA512 b6b0d5022da9de27417f8cc72ba24f0d51e57f83c68b17a296269b074888a711d61fcf933fbbfaf4d6977702b3f020d4b0eaa89e78e51185ee2dd26e911fe8be
+DIST sphinx_gallery-0.16.0.tar.gz 432247 BLAKE2B 130800616a29be2daedb77404f79ca8d1543ecd391f45f8f19cbcf46ce742d02725d9b087be337d11496021b5c486c6c24b35f22b2c7d4cb575cb2c217d328db SHA512 b45e9141d64b1e277d75f501f2cc40979942953cd8412716e5af64917a3b9adc0a746fbd6249c3636c3db222c1e438ee7f9a9ad93f57b2f05f9ec80a562796c3
EBUILD sphinx-gallery-0.15.0.ebuild 1433 BLAKE2B bbe6587cd21c184aef29eb7e0c3a8035ba3535405472d90dfa57a1ccd8953676ba2119576243e24256fba355eaa47e2d563523d9baa06ac7a5a92f641a995068 SHA512 ad94c565ce77847be5730125ab4ec8ea34186d744630a681eea5ad1c25d97d7275ca084b2f2d670aeb6cdaa415a472134c2bce8fede1928a10c6954ace08b89d
+EBUILD sphinx-gallery-0.16.0.ebuild 1466 BLAKE2B 8d09152d26e3ff9f583ae1244949e675bf249937c153eda527054ef64acd102d4175e7ff8d4417d1f46b0b4df5ab122b732044b3a4869eb8aab09cf1866ae044 SHA512 89e43d984270cfb3176ab8a54c270ba59e4a967fd214e8a3974d72d068d4308fd849439bdae3fdc5f2b108442e2f1f265599f635689b76cfee2fc28c0031d413
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.16.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.16.0.ebuild
new file mode 100644
index 000000000000..28e368e47dd3
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.16.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+ )
+
+ epytest -o addopts=
+}