summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
commit4d9aef45678c7cb55b24107642790224ab8c153b (patch)
treeb1c56639785aeba23901272429a46e4e872a7711 /dev-python/sphinx-gallery
parentf09a6cf772eb2f757f0fc49f3297d6a095a10aa5 (diff)
gentoo auto-resync : 19:08:2023 - 09:38:07
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 635e91bf5796..1394333751a4 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-gallery-0.13.0.tar.gz 403284 BLAKE2B fac67eab0c49a756f4b73b05434c80b5876d241afae66bfd4d2f50b5ffb715f03da3e87146531c90632ecef0d092c5d087c3ada0d01a6df21c8032b3b60d1890 SHA512 26168e25ff46a34d7cf1d2d70e59d5e81bab6e57ec497f2a6e55e5356fb832b8fefc5a19976cc4fb495fdc1ef8b44a33de93cc7a6f376f72c9dbcaa94ed723ef
+DIST sphinx-gallery-0.14.0.tar.gz 408734 BLAKE2B f527eb58b565353722d669edf81a667b7c3e784480500ff03b5567b9214c27951438052db3f2dcba92b24e7224d5cd0017bfbe770132dc96ce3427ca463329a8 SHA512 c8a69af9dec9adf042214de0cb48d510ebb41d7bc4bb1e5767f3982b0e83d9dfa1a26028d939a1785d3894894d396840e437dc5c196bfc5318152d06240d84b9
EBUILD sphinx-gallery-0.13.0.ebuild 1489 BLAKE2B d0ac54e3b7a00537b93c25d2659ba5d12fb40ae7676e080a0a108f3337e8c616354eca757dfb315f806d97d1186419e2670c7d44f63b909514cdb938e5481071 SHA512 e83c66891e9ed3d1fa2b16a9fe619989b4d265f5dbc4ecde5da53ef8c6057fd5f65150083c9f9aca9f0c7bd5dc4e46c7e4a8112b67e61f295c577c0ecc46e928
+EBUILD sphinx-gallery-0.14.0.ebuild 1437 BLAKE2B d504aaefd33ef640b085d99878fe9ca8236f7e831feb87923c6be11dad6c5b4b3ce6754926677e2b911808e8972e96da4345d3f5d87f88845dd1400da73c671f SHA512 70c65976eb00d5a8e260abded16fa4e4db7498ccf948121f492ee564c55d8700394c11d5f446201e1181765bfae70d8f9a623532f5f6378014fe4d6f23ab2898
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild
new file mode 100644
index 000000000000..2dbbb033b4d7
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+ )
+
+ epytest -o addopts=
+}