summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-12 07:05:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-12 07:05:45 +0000
commit669bfefc6b9cafab1e89f098b21cf0f89c12d995 (patch)
treef91d27f9ed331464c5a576bb2a739afa5c16d98d /dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild
parent5c273534e10d0e86a5941f9ba9c4ed87b90f0dd1 (diff)
gentoo auto-resync : 12:01:2024 - 07:05:45
Diffstat (limited to 'dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild')
-rw-r--r--dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild b/dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild
new file mode 100644
index 000000000000..c1cf8b5e4213
--- /dev/null
+++ b/dev-python/sphinx-celery/sphinx-celery-2.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Celery Sphinx Theme and Utilities"
+HOMEPAGE="
+ https://github.com/celery/sphinx_celery/
+ https://pypi.org/project/sphinx-celery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.0.0[${PYTHON_USEDEP}]
+"