summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-basic-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/sphinx-basic-ng
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest3
-rw-r--r--dev-python/sphinx-basic-ng/metadata.xml11
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
new file mode 100644
index 000000000000..740f45c25842
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-basic-ng-0.0.1.a11.gh.tar.gz 21539 BLAKE2B 31707bc8f3c6cd0c1af1aeff309543889119d33e5f5ae33194b58f88a0ff6ec424c5b876fef36b64161932ebb69c0f6108801697b49d47e10ad13affcf89e1fa SHA512 e9f9278a360d2c8d25a6679134d2d54b37c9f2e55285592fa910c85b2f8bfd4ab13d117b7078cb67d862703f8054c3d3a3ca68152551d67a26d7c1a8b75952ff
+EBUILD sphinx-basic-ng-0.0.1_alpha11.ebuild 933 BLAKE2B 9646b81d0cc472d7ae756ed8d7ade85d3aee4aef7ebff30d03d0ce8e1a94d9939791fe6de5a96228c0ae30adb8577664ce5d0133fdc637dbcf89a7a8529e164c SHA512 6920698923ec4c4cb6c99430b6ddce432b49f10bdf2c99fcf477eb4973b9908cfb82d1ec1b7b319607e2066bc992545e778caefcd7943ebb85abefdcf65b789d
+MISC metadata.xml 362 BLAKE2B a93dc662c8ab618397c8d0504342e8f1bd74226b131ea4ca07771cdeb75eb8947451b4353c0da16760f07f935ebb75adcdef4f189ff39e0cf707d03e8fa319e2 SHA512 fb27130b3fcff9043b3ad33e34c92f638cae46d526dcbe77cfe088abf80e6b89992edb1e0b571a5a2447bc6c8ba31ae84776d153067a33b5d6d14326149e7f46
diff --git a/dev-python/sphinx-basic-ng/metadata.xml b/dev-python/sphinx-basic-ng/metadata.xml
new file mode 100644
index 000000000000..43822aecf33b
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pradyunsg/sphinx-basic-ng</remote-id>
+ <remote-id type="pypi">sphinx-basic-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild
new file mode 100644
index 000000000000..b9693a1a852c
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/.a}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_alpha/.a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}