summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-07 06:12:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-07 06:12:40 +0000
commitff3ac0b17b39e52a4fc9ca04d17a5535c8f6085c (patch)
tree71efa15498950476bf57b0f5c1d158d9ee985071 /dev-python/sphinx-autodoc-typehints
parent86bac35ed1b4f7018bc03aea5551f7664a2b9ff4 (diff)
gentoo auto-resync : 07:01:2023 - 06:12:40
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest2
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.20.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index c46134fc9676..fa19daa59fe1 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-autodoc-typehints-1.19.5.gh.tar.gz 27758 BLAKE2B f73b0afa3656949f5aa14c8055020bccd81ff5f81df6dbf7c95d3656597d1e2e12918f77c6af56afb5c3ec28680e270aaa81c3d149b5427872dd8844bcaec495 SHA512 90cc5bb81e0a76ea3e476e3821299573ea0deaef0e007d2f83e0ff442db34bccf6e1078a4e06243bf19c8ee964477b924369ebbffb6ab4aa1cd673b16b0c79b2
DIST sphinx-autodoc-typehints-1.20.0.gh.tar.gz 27988 BLAKE2B 00dca24835ecaef8a2ebb9e0e918da39b5a7c72d946d654f4aec50777ce222b86f267bd8ab43deeccf802326fc067fdbbc03d5836322a233c9b48bb184995589 SHA512 6c807206d0d5abb0ec9afa03706271afbd9130dc41c1a591021a8656f518f66d057f601b27599fb6f7de3c4633747ff8a62c204759afad96784f4356c1e64be9
+DIST sphinx-autodoc-typehints-1.20.1.gh.tar.gz 28374 BLAKE2B 87891c5ee6b1fa76b12fd09a77c7de3e739cf95b76d0e3dd215feb585d9b07e883998c8e1a1a493230add7e8362278c750a0412d8e3d5102698e8e91e8042a4b SHA512 f8194c823c496c62dc6fa2d46595e39ec5da8f6661ceb3fc553a81f0a33604c00f3a4d742132326dca19c62cd32e7898fcfe89af862dfbc663b940bd4f9808a9
EBUILD sphinx-autodoc-typehints-1.19.5.ebuild 1070 BLAKE2B ddc5ab1da6afa9b9a6bf14ec2e0b5ea795464acbaed8443f10f3c304ad362f32e8943985e2f6263ec8be30947b613584dc660849106df6379eff3ad00939916e SHA512 5a9ffcab19263ed5074214aa1aa4ef272dfed91034640c13b64e2340329e90cd8b06a03f653e2def28163c7fe9457697cc7d31594e2b132817e3566b825e6b1c
EBUILD sphinx-autodoc-typehints-1.20.0.ebuild 1077 BLAKE2B c52a655b40d1373c77d3cc6eaad89e3c8367d35c397cab3f53099a325cbd55667da3db6bd20de6ccc92f6e9a8891e04e32abba852b55608de2dd03800427e281 SHA512 51d7d754957843fd82a2e57790b0af4575d55bcfa4089bdcecdbd2a39e317b909aa1f3035f5d49dce894030772929b06c3d7f17505b4497dab535189e29943a2
+EBUILD sphinx-autodoc-typehints-1.20.1.ebuild 1077 BLAKE2B c52a655b40d1373c77d3cc6eaad89e3c8367d35c397cab3f53099a325cbd55667da3db6bd20de6ccc92f6e9a8891e04e32abba852b55608de2dd03800427e281 SHA512 51d7d754957843fd82a2e57790b0af4575d55bcfa4089bdcecdbd2a39e317b909aa1f3035f5d49dce894030772929b06c3d7f17505b4497dab535189e29943a2
MISC metadata.xml 807 BLAKE2B 368714db91017473456e0854b7e2024ac6d24b4ba3d5ae2a44697546c4f96185a44ecc9da8dc816d9661f5815d7d31751d2d87d599c748d06db3f1dde32a141c SHA512 04882668dfa68354aa8ee5860db11963153fb29d9c26b3367fcef63da4ebbccf049909946e73fd06250bf784dcb783b1bc70fb29b9aaa1fcb19be9fcf470ebbe
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.20.1.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.20.1.ebuild
new file mode 100644
index 000000000000..e132b0c73ad1
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.20.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}