summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
commitc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (patch)
tree7775fcc8916726b2e7a58d7a251dee69292d231f /dev-python/sphinx-autodoc-typehints
parent23fb10c075a74a6504647a16c3e06a6378e208c8 (diff)
gentoo auto-resync : 29:07:2022 - 15:07:44
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest2
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 785c6fcb8e3f..cebce35814ae 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autodoc-typehints-1.18.3.gh.tar.gz 26457 BLAKE2B 343a6ffcbca40f28a66c67266431f3a9b2292bd0d991de4287b9adf9e02b7d8fb24094646caa55790f32cd9081abca525f310367335d60fa1b7ea3bc9623bb1c SHA512 549bdfad8f5c07f5edb1c6cdeaff39df22cc7bfa475c70b5c54ff46b311d14c9f3682bf68663d852b95ebff8fd1b71038fc077495d99d870ae2efbf72ec99a42
+DIST sphinx-autodoc-typehints-1.19.0.gh.tar.gz 26950 BLAKE2B 4e530c0b16500d8489bed7f50518b1bc30fdc824d41eb6cc66786096c09c910deb92ac580438395e3b71fd2d3b64690986cb035ff2d784e26918a42bdc73d8fc SHA512 d9459aca1091da0fa446d7ce72ef83c172775b66081d87431c14fd9cfda42770dbd08450ff193e3accffe0eb11efde22804e4ffff20a8e0e9072a05bc34a99e9
EBUILD sphinx-autodoc-typehints-1.18.3.ebuild 1066 BLAKE2B e43ac460f86ddb31256e3e303b3837f542d0b2b296eb3b917f877dfdd426b542b779d6ca0e4036e80d6689e8de3bda3c2259923400bdf6dc9a46faa6fa6ab012 SHA512 d841abad7e984d33a332262f92eade154363aec0f1fa9588381e6ab9c1c6f0e193f05ccc5d5f9755df52429f096238f2c1b51e2040ae24cca027a5d3fe8492c1
+EBUILD sphinx-autodoc-typehints-1.19.0.ebuild 1073 BLAKE2B b7579a2dbe8747265b60eed1d96627561447d2631279c5793f6eee56dfba83e74f21c21eaca4585de78380722da1ad567945c4053b058891172a2b91645f80e2 SHA512 a68916030b5b9a2b0b4e14ff548ba23a3f4df1baa7e0633436b91fdf4a1ba5b4d1a7d937fc44ed637c262192a1c437d4e78b698b6c1294967e078d955cdb3c58
MISC metadata.xml 807 BLAKE2B 368714db91017473456e0854b7e2024ac6d24b4ba3d5ae2a44697546c4f96185a44ecc9da8dc816d9661f5815d7d31751d2d87d599c748d06db3f1dde32a141c SHA512 04882668dfa68354aa8ee5860db11963153fb29d9c26b3367fcef63da4ebbccf049909946e73fd06250bf784dcb783b1bc70fb29b9aaa1fcb19be9fcf470ebbe
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild
new file mode 100644
index 000000000000..9eca6f1f4db5
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-4.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.1.1[${PYTHON_USEDEP}]
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}