summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
commitb43ae231a57eccda208f33c4343d956e7f2590f5 (patch)
tree8871b66b51dfb514ef803c4eaf3d1f2cb57c4ee1 /dev-python/sphinx-autodoc-typehints
parent7e84f2c47ae7a0e8b76fc3080b1c7ee8487ee76b (diff)
gentoo auto-resync : 31:10:2023 - 21:49:19
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest2
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.24.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 1324ea05378a..9bffa0f624ed 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,5 @@
DIST sphinx_autodoc_typehints-1.24.0.tar.gz 36127 BLAKE2B 46f9eb12b7327dceaf623bcf76a0a58a7805e1e917f4617e0dada7a1f8511af9045acc4f318e0956e1fe43daec9e154f1cc0ba932dd01cc4b45ed968221046bb SHA512 f56aa2f937e1cc0063b1776d4b46e51f9ec390fc07c603ac502e19f7b859815802145f61a1bebd2c7b57ae394549119040a88829ba477cc1e1c2da1ef5782f34
+DIST sphinx_autodoc_typehints-1.24.1.tar.gz 36436 BLAKE2B be1de2ea15dd39f4adb30028849645b69a7f21aec7997a3fd633a5ba606a78e8f095b6a05bc66242003670adf5846c7b444ffd5eead39e0a7836f097ed0a3302 SHA512 d79f540939a8e669d0aaf238a213aade330ed46112231adae3ca822afdf5d12178247afc4a2a46938dc49aa73e556d0303db28e2ff48ebf6e26ddf71a7759c4e
EBUILD sphinx-autodoc-typehints-1.24.0.ebuild 984 BLAKE2B b93955db3b1638a9177d7e02601f7dd64f9afb45e368fa3d9dd93589ba516243cc08e7d9d9b17f32dfa0238e8ca1e4e1370f4335df18ba40b361ee965f5748c4 SHA512 86ab3cec485f3b347a5d27f238cd14fb5725e71ab656466f24d86f3a5d8b32729abe1a7a8724009db4a4b9318b684a2704e461ebab12dfdcc67cd986e8dc87a4
+EBUILD sphinx-autodoc-typehints-1.24.1.ebuild 993 BLAKE2B 6e2ad1da1a3c18bf70ae2ee7d8278b5358e73b2a1901d2a841b56a27cc861ec659b701388dedaf7017f07df2484a4bd0cdc91e05efb7e775e76b331a51266799 SHA512 8b6037fcffbb572e794bdd73cadccd71bd43b4b136e1a127cb4b56de18b6f4669ec9e19cbcac52269ad3de4778b1b13f99368a725cf26603dbb5b7eb6b6d7cd1
MISC metadata.xml 682 BLAKE2B f8b48894f28411a17c73956bb75d43906c893b33d3dc611dfcc46e7a71ac43824aa54f660ab4f49c9870248b2b9ff405a2a3229f92975337e69201868eed3378 SHA512 87a0ea2b2e4cb2b5f0d1593b2c4bd96b46dabb8baae71a6ba18cfd83dedb2a1d5f0ae0f8711144967a5d44015e9ae7ca013dc0aa54e20604633ae062d95649ef
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.24.1.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.24.1.ebuild
new file mode 100644
index 000000000000..bfedfcb23611
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.24.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)