summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
commit3ca7a521e79841f7247feb67780a70722c997d55 (patch)
tree30b9afb1b822575d8e6ac4009489795a105a56ce /dev-python/sphinx-autodoc-typehints
parentc268590c556cb766e1ca3f55fde8a40cdde19c44 (diff)
gentoo auto-resync : 27:09:2022 - 21:10:48
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest2
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 6789de2d9ab4..e852d11c86a9 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-autodoc-typehints-1.19.2.gh.tar.gz 26983 BLAKE2B 694edbf94bac05670adad992cfdc7e1146228af7b888a97c4f8e2394623ef3e42251ba0f3c22985517b2a251996cc41a305ea5497b2369363bc00d4bb3d24da7 SHA512 c35c7ed3f0698651be5ba4dd2232912d1f6d9d30e08153527df3fe16001266abc80cd1b11e3a41ccf92140c6baea98105e9bccd9466e65664dcf008f9a944634
DIST sphinx-autodoc-typehints-1.19.3.gh.tar.gz 27694 BLAKE2B c1528fa4d4e055dab723bfc40baea591a201546abdccbb81e7dd9ada8620ea74d7371f9c47a8ef310f57934de95b5c295939fa9c095492e02606ca9828bf921d SHA512 fba1b5b39b9c8556ffa75e1a9d2427623bb8ee6f412b78c293c77b248b81d73f624beca9c155279147951510daed7cf5a5120e714efbcce4d62251f74f0924a4
+DIST sphinx-autodoc-typehints-1.19.4.gh.tar.gz 27724 BLAKE2B 5d22561515286a3530a86dad5cf80f0f66068ee50e10a60513dc66bb17be9a8aabb10fe9a35dd6cbeddc6eb78c2403e8f880cbed01e048c5bb3ce48716ff6bdc SHA512 d36a8b3f32dfb6204a248b91f20882b97efa9aa746cd9eeb445945de165511ddce4f9d3cc63799a5f9acc5b2fa6a4352eb7205e679b8937138a12cc462c94056
EBUILD sphinx-autodoc-typehints-1.19.2.ebuild 1066 BLAKE2B e43ac460f86ddb31256e3e303b3837f542d0b2b296eb3b917f877dfdd426b542b779d6ca0e4036e80d6689e8de3bda3c2259923400bdf6dc9a46faa6fa6ab012 SHA512 d841abad7e984d33a332262f92eade154363aec0f1fa9588381e6ab9c1c6f0e193f05ccc5d5f9755df52429f096238f2c1b51e2040ae24cca027a5d3fe8492c1
EBUILD sphinx-autodoc-typehints-1.19.3.ebuild 1077 BLAKE2B 4e9ade2d098b25db13a49fd2f63cff7045af6a5ccd098d8d69f019d179a7feab1f9452c7bff6e80f4dd6a67c549b1eb7c5cfeb5084202e1519b277fe5520c5c4 SHA512 76d5fbd4b18a28db31758010d2917d3f69f5b1caf405c96f849cced5bcee225dd4580ee3c789b49b406eaa801be3d1aa13f809f532ea7f01572870385349dade
+EBUILD sphinx-autodoc-typehints-1.19.4.ebuild 1077 BLAKE2B 4e9ade2d098b25db13a49fd2f63cff7045af6a5ccd098d8d69f019d179a7feab1f9452c7bff6e80f4dd6a67c549b1eb7c5cfeb5084202e1519b277fe5520c5c4 SHA512 76d5fbd4b18a28db31758010d2917d3f69f5b1caf405c96f849cced5bcee225dd4580ee3c789b49b406eaa801be3d1aa13f809f532ea7f01572870385349dade
MISC metadata.xml 807 BLAKE2B 368714db91017473456e0854b7e2024ac6d24b4ba3d5ae2a44697546c4f96185a44ecc9da8dc816d9661f5815d7d31751d2d87d599c748d06db3f1dde32a141c SHA512 04882668dfa68354aa8ee5860db11963153fb29d9c26b3367fcef63da4ebbccf049909946e73fd06250bf784dcb783b1bc70fb29b9aaa1fcb19be9fcf470ebbe
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild
new file mode 100644
index 000000000000..b61995da51f2
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}